RSS feeds disappeared

I have a couple of rss feeds set up. With the latest update the rss menu seems to have been removed/integrated into the news feeds menu. The feeds I have set up are still visible if i go to the web interface, but I cant seem to find them in the player interface. Have they been removed or am I just looking in the wrong place. Is it still possible to set up rss feeds via the web interface?


What firmware are you running on the unit?

To our understanding no changes were made to the RSS feeds.

Have you tried resetting the device?

1 Like


The firmware is 2.01.86

It’s not a feature I use very often, so I can’t say when it disappeared, but I’m pretty sure there used to be an “rss feeds” options in the main menu, this has now been replaced with “news feeds” and all my subscriptions are gone.

Also, the option to add subscriptions via the webinterface, which is so much easier than typing urls with the remote) does not seem to work any more, I can add subscriptions, but they are not shown anywhere in the device menu.

I have not tried resetting the  device, and was sort of hoping that would not be nescesary, but of course, if nothing else works, I’ll try that.


Ok, I was to hasty, the webinterface works, so the only issue was that the subscriptions disappeared, but those I can readd pretty quickly. Again, thanks for you help.

I use the last soft. 

All my feeds disappeared after I add another one.

What`s the **bleep**! I use the devise seversl monthes and nothing changes to better.

Why should I by WD next time?