RPi3 and Pi Drive, getting Lightning Bolt Icon in Raspbian


#21

There is resistance in the connection where the USB cable plugs into the transformer. And also where the other end of the USB cable plugs into the “Dragon Cable”. You can get better/shorter USB cables, but you will still have resistance due to the physical connectors. WD may want to consider providing a transformer with a permanently attached heavy cord, that goes straight into an integrated Dragon Cable. There is really no benefit to have a removable USB cable connecting the transformer to the Dragon Cable. Plus, it costs more to manufacture, and lowers performance. Make that cable non-removable, short, and heavier gauge wiring. The whole power supply chain - the transformer, USB cable and Dragon Cable - should be one monolithic thing, and doesn’t need to be more than a foot long. If customers need more length, they can add a standard extension cord on the 120v side of the transformer. You could even get some aesthetics person to design a nice little stack setup - the Pi case sits on top of the PiDrive case, and the transformer sits on top of both of those (color it white to match). This would probably go a long way to solving these consumer power issues.

It’s so typical that design effort is put into the complex thing, the Pi Drive itself, but it’s the simple thing, the power supply chain, that comes back to bite you in the rear. Been there, done that!


#22

Hi, we expect to receive 1.5ft cables within two weeks. Pleaser provide your shipping info including phone number and I’ll send you one when they come in. Thanks.


#23

Deleted by Moderator (Privacy).


#24

Got it, thanks. Will send once we receive the cables.


#25

Hi,

I am having the same issue with the dragon cable and 3 Amp power supply kit that I purchased from MCM Electronics.

I have a Raspberry Pi 3 with the 7" Touchscreen, a PiDrive 314GB and an Ethernet cable attached. I have added max_usb_current= to my config.txt. Like Robert_Morris, When I use the official Raspberry Pi 2.5A power supply I have no issues. When I use the WD 3A power supply and dragon cable I get a low voltage warning (the lightningbolt).

Do you still have better cables available?


#26

Hi, yes, we received the lower-resistance 1.5ft power cable. Please email me your shipping address including phone number. My email is dave.chew@wdc.com. Thanks.

BTW, since you mentioned Touchscreen, I have a pilot product in the wings that provides a mounting solution for the PiDrive, 7" Touchscreen and one of the popular Touchscreen cases. See the PDF at the link below. It can be configured as desktop or wall-mount. It fits our 7mm PiDrives (250GB, 314GB, 375GB; 1TB coming this summer). The kit is three plastic adapter parts and screws. Pi, PiDrive, Touchscreen and Touchscreen case would be obtained separately. I have beta test samples available if you or others are interested. Thanks.


#27

Dear Western Digital Support,

I have just finished setting up each of the “project areas” using the included WD PiDrive Foundation Edition - English software and 375gb USB drive with RPi3 upon the last reboot there was a boot failure due to file system corruption on the WD PiDrive media. This failure resulted in just “4 RASPBERRY IMAGES” being displayed no matter with area was selected. The product that I was working with is the:

WD PiDrive Compute Centre

I am assuming that the Lightning Bolt icon, that I thought was a Temp icon indicated that the standard cable/power adapter that was included with my kit, caused this “brown out” and thus the corruption…

There was issue with file system corruption (possibly each /boot) when SD “project area” selection was chosen and :

Projects Spaces replaces the need for multiple SD cards to manage different projects for your Raspberry Pi. A “Project Space” is a vanilla install of Raspbian Jessie Lite that can be used to test code or create different projects in their own isolated environments. This prevents elements of your separate projects to conflict with each other across Project Spaces. Each space has its own /boot and /root partition…

I do not know if there is an issue with the actual PiDrive itself or with the SD boot selection:

Since I can not access the WD PiDrive using a standard Raspian SD boot media, I am unable to determine which /boot files are corrupted…none of the separate Project areas will successfully boot.

I am attempting to reinitialize and recreate each “Project area” again…by using recovery boot as none of the previously created sym links function… only the 4 Raspberries at top of screen once the OS is selected…a waste of a week of customization… too bad we can’t select the OS for each Project Space…I wanted to Multi-boot into a few different OS’s that I’ve not used since 2014…

I have also noticed that over 300gb of disk space is unusable now as well, because this Foundation Edition is preconfigured to create 2 x 8gb, 2 x 16gb, and 1 x32gb project space, with another primary for Raspbian that’s ?..

so How can I tell if my USB power cable is wrong resistance and that there isnt further damage to the 375gb USB drive

contact info:

Order Number: [Deleted-Privacy]
Order Date: April 23, 2017


#28

Hi I have been looking for this enclosure to add a PiDrive to my Touchscreen RPi3’s

I’d be interested in a sample if available to test


#29

I have the same problem, but I tested a Dell 10W (2A) Adapter instead of the Ktec that was supplied by WD and it works fine. I am using my pi as PVR with tvheadend and with the Ktec adapter my USB-DVB tuner is not working.
So i measured the Watt on the input side of the USB adapter. During bootup 5.7 Watt at max from the Ktec adapter, the Dell one supplied 7 Watt at max. (1.8 meter amazonbasic usb cable)
Charging my phone (bq aquaris x5 plus) 7.3 Watt from Ktec, 8 Watt from Dell. (short usb cable that came with the adapter)
Connected my phone via 1.8 meter amazonbasic usb cable into the “dragoncable” + pidrive (1.2 Watt) = 8.6 Watt Ktec, 9.2 Watt Dell
Charging my tablet (Dell Venue 8 pro) directly results 11 Watt from both. Via “dragoncable” + pidrive the Ktec goes up to 12.3 Watt the Dell remains at 11 Watt (seems to be max because of 2A)
cant see a cable problem, needs to be something else, maybe low voltage on the Ktec. Does anyone have an USB multimeter?
thx


#30

I did some more testing. The Ktec supplies 5.1V and the one from Dell 5.22V. The USB-Port of the pi 3 supplies 4.8V vs 4.92V, which seems just enough to cause problems even though its still within USB-specifications.


#31

I had some time and did some research on the internet and found that this is a common problem.
Adafruit even built an USB-power supply to solve this:

“This adapter was specifically designed to provide 5.25V not 5V, but we still call it a 5V USB adapter. We did this on purpose to solve a problem that occurs often with USB-powered gadgets: they draw so much current that the resistance of the cable causes a voltage drop, so instead of 5V, the device sees 4.75V or so.”

So to me it seems like WD-Labs did not do their homework :wink:


#32

Hello,

I wish to make a project of digital photo frame with the pidrive 375 GO + the official screen and the screen support.
I see in previous reviews that most people who purchased the 3A power supply have voltage problems (the small yellow flash).
So I would like to know if I order 1 or 2 3A power supplies on your site, would I have the same problems? Have the power supplies been changed since the last comments?

Your HDD support presentation behind the official screen interests me a lot.
I ordered the 6X6 box to make my project. But yours is downright better. Would you still have 1 sample for my project?

Thank you for keeping me informed.
cordially

PS: Excuse me, I’m French, I use Google translation.
Thank you


#33

I’m also running into this issue. I have a Raspberry Pi 3, 1TB Pi Drive with the 3.0 amp power supply and the only other peripheral I’m using is a Logitech wireless keyboard with trackpad attached.
These are the issues I’m seeing:

  • When playing video using omxplayer I’ll get the yellow thunderbolt icon for a few seconds sometimes.
  • When I try to access the pi drive the first time I open it in the file system the window is unresponsive and I have to open another window to look at the files in it.
  • Sometimes the pi drive will temporarily rename itself from “Name” to “Name1” so that scripts I have trying to access the drive fail. (My drive’s name is Windfish so it becomes Windfish1)

If I instead plug the cable that powers the Pi Drive and Raspberry Pi into my desktop nearby I have none of the above issue ever. This has been an ok temporary solution but I’d really like to have my Pi not rely on another machine for power. Any ideas on what to try?


#34

I’m trying to submit a support ticket for this but I can’t because I can’t get the serial number off of my drive. The pi drive enclosure is impossible to open once it’s snapped in. Any help would be greatly appreciated :frowning:


#35

I just received a WD PiDrive Foundation Edition 375GB, a WD PiDrive Power Kit (3A), and a WD PiDrive Enclosure - Blue Square 6"x6". I have put it all together and I get a Raspberry Intermittent Yellow Lightning Bolt just sitting at the Home Screen. Help would be greatly appreciated.


#36

I got the Pi Drive because I wanted to be able to power both it and the Pi with one cord but my only solution to this issue was to power them separately. Because of this I don’t recommend buying the Pi Drive if you’re reading this. Buy a cheaper, powered, external hard drive, power it separately from the Raspberry Pi, and you won’t have an issue. :man_shrugging:


#37

I have two pidrives that work fine. I had to get a different usb cable to go from the power supply to the pi drive cable.


#38

It’s an issue with the cable from the power supply to the Pi drive cable. Needs to be a thicker gauge.


#39

I bought the Pidrive Compute Centre and am having similar problems; installing and updating everything goes without a problem as does browsing but when, for example, i visit youtube and try to play a video full screen the lightning bolt icon appears.
Please note that this is just an example and first observation from someone starting with RPi; I don’t care about youtube videos.

Also not looking for handouts but if someone could point me in the right direction of which cable i should buy or tell me what to look out for, that’d be awesome.

So far very happy with my Pi <3

Edit: I’m just using the out of box setup, nothing extra connected besides a 1,8m hdmi cable which i’ll be replacing today with a 0,5m one.

Edit 2: Bingo! (i hope) 5.25V 2.4A Power cable


#40

Hi Dave,
Thanks for your assistance on this thread. It’s good to see transparency and support. As a new user to RPi world it’s taken me some time to get up to speed and recognize I too seem to have power issue with WD 3A Power Kit.

Last April I purchased the RPi3 model B with WD Labs PiDrive 1TB drive, dragon cable, WD Power Kit and WD Enclosure + Rii bluetooth keyboard + USB adapter. LAN is wireless. Audio/video through HDMI. No overclocks.
Have tried several different OS/distro’s but settled on OSMC/debian as it’s primarily used as a media player. Since the beginning I have been plagued with the “lightning bolt” at various times but could never determine root cause based on usage. I attributed it to s/w bug since it seemed to have no obvious impacts and was periodic.

Recently have run into issues where lightning bolt has been appearing more frequently and RPi has begun to consistently lockup, freeze and drop off the LAN during large wireless file transfers - requiring reboot. I assumed corrupted o/s so reflashed and rebuilt yet same issues persist. Even tried different SD card to no avail. Looking to narrow root cause I tried using 2 separate powered micro-USB connectors. Surprise! It worked and stable - no lightning bolts. Problem seems to be isolated to the PiDrive Power Kit.

Has WD committed to building a new PiDrive Power Kit - and are you able to indicate when? I do like the idea of a 3A “attached” cable so crossing my fingers this is in the works. In the meantime, would you be able to provide a shorter low-resistance micro-USB cable replacement? I’ll send you email similar to other requests I’ve seen in this thread.

Thanks for your assistance.
-Rick