RPi3 and Pi Drive, getting Lightning Bolt Icon in Raspbian


#1

So I’m using the 1TB Pi Drive and the 3.0 Amp Power supply both from Western Digital and I’m getting the lightning bolt icon popping up in Raspbian a lot. It seems to indicate it’s not getting enough power. I would assume that power supply should be able to handle it, could it not be enough?

EDIT: Just as a side note, I was previously using this 1TB drive with my old Pi B+ and the smaller power supply it came with and that worked just fine.


#2

Hi, I’ll just double-check some items with you as a baseline:

You’re:
Using the PiDrive cable (we call it “Dragon Cable”).
Using the USB power cable that originally came with the 1TB PiDrive.
Using WD Berryboot or PiDrive Foundation Edition software or have manually edited config.txt to add max_usb_current=1.
Not overclocking the Pi

What else may be drawing power, such as:
Ethernet connected
Camera or display connected to the ZIF connections
Other USB peripherals attached/active
Non-powered speakers or headphones attached to the audio port

What application(s) is/are active when the lightning bolt is most prevalent- is there a trend?

How frequently do you see the lightning bolt (i.e. about how many times per minute)?

Thanks!


#3

Original Pi Drive with cable, different power supply (3 amp version from WD with micro USB cable). Not over clocking but also did not change that setting you mentioned, I used Berry Boot to install Rasbian. It was showing just booting up and if I opened the web browser in Rasbian or opened anything at all. At rest it would show no lightning bolt but even if I opened settings it would show. Only item also plugged in was a Logitech dongle for the wireless keyboard trackpad combo.

I went ahead and used another micro sd with Rasbian and only the keyboard plugged in and saw no issues.


#4

Hi, sorry for the delay. After your last post I started to do some testing and I confirmed your observation of the lightning bolt. I hadn’t personally noticed this before on this configuration, but also haven’t seen any signs of operational issues related to powering when the lightning bolt appears in this nature (frequency and duration; when testing with lower-current power supplies and long USB power cables). Based on R-Pi forum info, the icon appears when the voltage drops below about 4.65V and can be triggered by current spikes. It stays on for 3 seconds when it’s triggered. The PiDrive has low-voltage protection that triggers write-protection measures leading to emergency head park. Under critical power loss it uses the back EMF from the spindle motor to power the system, abort any write operations and park the heads. This situation would occur at a voltage level below the spikes/dips observed here and I’m working with the team to get more specifics. I’ll continue to do more testing and provide more info on this. Thanks.


#5

Thanks for looking into this! I had this same Pi Drive set up with my Pi B+ and the same installation of Rasbian but do not get the lightning bolt (was using the original power supply that came with the kit, not the 3.0 amp version).


#6

Just a real-time update, pardon the hackage (I’m not an EE!): see the video at link below. Narrowing down on the bottleneck. More later…


#7

Interesting, let me try out with a different cable.


#8

Update 2/24: shorter USB power cable helps- see new video below:


#9

Hi paulornothing, forgot to mention: I can send you one of the short cables (by Anker) so you can try it out. Just need your shipping info including phone number (required by our shipper) emailed to me: dave.chew@wdc.com.

Thanks.


#10

Thanks for looking into this. I was just going to shop around for thicker gauge USB cables. I’ll send you an email with my information, that’s mighty generous of you! I plan to use mine as a server and I don’t want to worry about voltage issues.


#11

Well, thanks for bringing this to my attention and for your help narrowing down the issue. Please send your shipping info to me (dave.chew@wdc.com) and I’ll ship out the short cable + … :wink:


#12

Good Morning, I have just received the WD PiDrive Foundation Edition 375GB Hard Drive, I also purchased the WD Pi Drive Power Kit (3A) from yourselves. This kit arrived 2 days ago, and I am suffering the same issues as the person on the 25th February. The lightening bolt appearing and disappearing. This appears to happen when the hard drive appears to be in heavy use. I am using a Raspberry Pie 3 Version B, with USB Keyboard and Mouse attached. Also a USB Game controller attached. All USB ports in use, (including PiDrive connected). Also connected are an HDMI Monitor via HDMI cable. A wired Ethernet connection, I know Wi-Fi is available on the Pi 3 but this is not really suitable for the location being used in. I have tried various ideas found on this forum, to no avail (USB High Current). This problem has only started since attaching the PiDrive and using the WD Pi Power Supply (3A). Previous use of PI3 with Raspberry Pi 2.5 Amp power supply (Genuine) no issues. Short version there appears to be a problem with your supplied power supply (Purchased) or cables. Need a resolution as soon as possible. Thank you.


#13

Update: I have now tried running the above set up using my Raspberry Pi 3 (Genuine) power supply (2.5A) and no lightening bolt at all. I now surmise that there is a problem with your power supplies. One of which I have purchased (delivered 2 days ago) for use with the above system. I await your response and resolution. Thank you…


#14

Hi, thanks for the info. We’ve recently determined that if we can further reduce the resistance of the USB power cable, the lightning bolt goes away. This is consistent with your observation using the official R-Pi power adapter which has an integrated low-resistance cord. The cable in our product has low-resistance, but we’re working with the vendor to drive it down further and will provide an update once settled. Meanwhile, we demonstrated no-lightning bolt using a shorter cable (1ft, which drops the resistance), and I procured some quantity of these and can send you one as an interim solution. Just need your shipping info including phone number sent to me email: dave.chew@wdc.com.

Thanks- your info really helps a lot.


#15

Just got my 250GB PiDrive kit. Using a Pi3 and getting the same issues as above.

Stock Raspian build from the included 4GB card.
All 4 USB ports in use - mouse/kb/PiDrive/Xbox controller
Ethernet connected - wireless inactive.
HDMI to VGA adapter.

Had thought the included 3A supply would have been enough.


#16

I don’t think it’s the power supply, it seems to be the cable which has too much resistance. Solution is either using a shorter cable or the same length cable but with thicker gauge wire.


#17

I did try another thicker gauge/shorter cable, but same issue. For now I used the power adapter to power the pidrive, and then the canakit adapter to power the Pi. Would prefer a one cable solution, but this works for now.


#18

Hi, I can send a sample of a short, low-resistance cable that shows improvement in my testing. We’ve sent some of these out, but I don’t believe we’ve sent one to you. If interested, please send me an email with your shipping info including phone number. My email is: dave.chew@wdc.com.

We’re working with our cable supplier on further reducing the cable resistance and will follow-up with the forum as soon as we have a closed plan.

Thanks.


#19

I’m having the same issue with a Pi 3, PiDrive, and the 3A charger. I suspected it might be because I was also using an ATXRaspi board to add a power/reset button, but I did have a 6-foot Anker cable around to test with. I’ve switched to that one and I get the lightning bolt much more rarely. It only seems to come up on bootup and when first loading a program, where before it was up over 50% of the time when using it.

I suspect a shorter, good quality cable would take care of it.

[edit] Quick followup, I also had an old HP Touchpad charger around that I’ve had good luck with. I tried that with the Anker cable, and haven’t seen the bolt at all. It outputs 5.3v at 2a, it looks like the slightly higher voltage may help, even with the lower amperage.


#20

I’m having the same issue with a Pi 3, PiDrive, and the 3A charger. What do i need to do to get a replacement cord? thank you…