Router hookup multiple computers with My Book

Ok here we go, asked support but they just said it wasn’t made for that.

I have a router coming next week, a wireless gaming router

View Router here

I bought the My Book  2TB at this link

My Book Here

What I had planned to do is connect 3 laptops  to do backups to this My Book.

All the laptops run wirelessly and the router has a USB port and hoped to connect the My Book to the routers USB and that way all laptops could connect through the router to the My Book.

Has anyone tried this or know if it will work?

As I read here it seems it is only made for like 1 computer but to me why have 2TB if hard drives are never that large for the most part, it would be senseless to have 1TB backed up over time if your HD was only 5GB in size, all the stuff on the My Book wouldn’t fit anyway on the computer, thats why I hoped that it could be used the way I intended on with my question.

I think there was a post on this in the last 2 weeks. I think they were having problems with the drive going to sleep then not being able to wake it.

1 Like

I will have to look again, I did a search and read some but none I read was like my question.

Thanks anyway.

Clicked your star but it didn’t solve anything.

I know your prefered method is a network drive. The alternative is hooking to a desktop and sharing on the network, that does work ok. You may have to look else where like the router manufacturer’s site. You may be able to use an old PC as a network server possibly with Linux. I think people have done that for sharing music and videos.  If you get it figured out post back. I’ve thought but haven’t got around to it. Winter is coming now and more indoor time!

The router will be here monday and I should have results here hopefully by Tuesday.

I connected the 2TB my book to the netgear router in the routers USB port and it listed the My Book just fine.

The router uses a built in thing called readyshare and now I seem to be having a time trying to get data from the computers to the my book.

I am also posting to the netgear forum to see if anyone else has tried connecting this way with a my book to the router and if I get a rely I will be back to share the results.

I’m trying to do the same… not possible yet…

I have Netgear N600 and My book elite 2T, not working hookup to router!



Well, mine shows in the router and maybe tomorrow wednesday since I have 2 backed up computers on the my book now which was manually connected to each computer I will try re connecting it to the router and see what I might make it do. I will report on any progress.

Same problem with me also. I can’t access My Book when it’s connected to the Netgear USB Share port. Have you found a fix yet?

I put it on hold seeing WD said it isn’t designed to work this way. I may try in a little bit today to connect it to a computer in the basement and see what happens as far as backups.

I fint it strange that supposedly you are suppose to be able to hook it up to a computer on your network and be able to do backups as it sees it as a storage area this way, but connecting it to a USB on your router is actually still on your network, so why it won’t work in this manner is a mystery.

A network is a network everything working on the same level as far as I see it.

I am going to go now and try it on the spare computer which is setup on a wireless print server in a different location to the wireless router.

Will let you know today if this works this way.

I may try the router hookup again, but as boggled as it seemed to be, I kind of put that on the back burner for now.

Update to connecting the my book on another computer.

I was able to do a backup using accessories/system tools/backup to backup my XP operating system to the my book.

I have 2 windows7 laptops also and unfortunately the thing with windows7 is they want the external storage to be on another windows7 system. That is dumb to me, but that is what windows7 says.

As far as using the menu that displays the HD files and the my book files dont seem to connect and all I was able to do was a backup in the path above.

I will still mess with it a little in the days ahead though and try it on the router again