Router cuts out when WD MyCloud is connected

I have had my WD My Cloud 2TB for two years now and it has been working without issue, but after the last update my router now suddenly cuts out and I lose internet connection completely. I am with EE here in the UK I have the EE Brightbox 2 router which I have always used without problem but as I said when the MY Could is plugged into a spare network port on the router I lose internet connection and all but the power light go out and broardband light goes from green to flashing amber. If I unplug the MYCloud and reboot the router comes back. If anyone has any ideas I would appreciate that.


if your cloud has a static ip, the settings might be incompatible after the update. if not, it might be something else :stuck_out_tongue:

either way try doing the 40 second reset which will clear out your static if you have one as well as resetting your cloud setup; all data will remain.

That is my only guess from another user…

Got almost the same problem. Had MyCloud 2TB for a couple of years, worked no problem with Brightbox1. Got the replacement Brightbox2 a few weeks ago and plugged the MyCloud in via an ethernet port as before. After a week or so the EE internet connection got pretty intermittant, dropping out for 3-4 mins., broadband light orange, then internet light orange, then all back to normal green. Eventually it stopped altogether, no access to MyCloud or internet, broadband light continuous orange, and I reset the MyCloud by pulling the mains PSU. Works for a few days then goes wrong again. The MyCloud has a flashing green light when i/n access is off.
The Brightbox forum sent me over here as they thought it was a WD problem. I have connected this desktop via the Brightbox ethernet sockets and it works OK.

Have never set any IP addresses up, and WD firmware is, auto update.

I don’t think that can be the firmware version of the single-bay MyCloud device: latest firmware is either v2.x or v4.x, depending on whether it’s Gen2 or Gen1 hardware. It sounds more like the version ID of one of the MyCloud desktop apps.

Have you tried the Brighbox1 router again? Your new router may be faulty. Alternatively, it may have some compatibility problem with the MyCloud (wouldn’t be the first router to do so). Try placing an ethernet switch between MyCloud and router.

Removing power from the MyCloud doesn’t do a reset. Pressing the reset button does. Download and read the mycloud user manual for details of how to perform the 4 and 40-second resets, and the effect they have.

Right, re-checked the firmware as v04.05.00-315 from the dashboard on this PC which is wired to the router, and which says WD is up to date. I already tried the previous Brightbox1 but it wouldn’t connect to the server at all with new configuration.
I don’t think I’ve got an ethernet switch lying about. Plenty of old routers.
I admit I never read the manual yet, just the quick installation!. However, as everything is working perfectly at the moment (following a MyCloud power down) I need to wait a week or so until its starts going wrong to see if a proper reset fixes it. The fault seems to be a cumulative sort of error that starts with occasional dropouts but builds up to being a 100% outage.
I’ll get back when that happens.
Many thanks.

If you’ve got one you can put into bridge mode, and then off DHCP server and WiFi access point, you should be able to get it to act as a switch.

I’m struggling to think of a reason for cumulative problems. Sounds more like a router problem more than anything; maybe the equaliser drifting off.

Back to square one. The Brightbox2 router worked fine until 4 days ago then started dropping out and eventually was offline more than online with the broadband light on permanent red. Which I assume is an equalizer problem.
Pulled the WD mains plug, ethernet still plugged into the router, the problem has gone away and the router has worked normally for 4 days. At a loss to know what to do next.

Have you tried using a switch in between the My Cloud and the Brightbox2, as mentioned/suggested previously?

This still seems like a line or router problem to me. The ethernet port side of the router should not affect the ADSL (broadband) side. If it does, it indicates some EMC problem in the router.

I’ll have a try with the switch later on. Not too expert setting routers up so its a learning curve. I had thought of EMC as cpt_paranoia said but the symptoms don’t seem to correlate with WD cloud usage at all, apart from being connected for a week. May I’ll put a SW radio near it.

More likely to be conducted emissions through the ethernet cable.

If the problems don’t correlate with MyCloud usage (I inferred from your posts that they did), then it may simply be a line problem, and nothing to do with the MyCloud at all.

So after many years of WD cloud/live usage, I can say with 99.99% certainty that it isn’t the cloud fault even though it may look like it; i.e. plugging in the cloud the internet goes down, unplug and the internet goes back up.

  1. make sure you switch off static ip and set it to DHCP. (This is to remove any DNS ip assignments of which I have now come to believe to be the main cause of all troubles)
  2. make sure you turn off all reserves or at least check that you don’t have reserves for the cloud.
  3. if you are using reserves, make sure you set them outside the range of the DHCP. e.g. DHCP assignments from to and reserves set at and so on.
  4. Shut down your cloud
  5. reboot your router
  6. unplug any USB attached drives
  7. start up the cloud

If you hear the cloud gurgling, the sound the cloud makes when it is scanning for files and you cannot get access to the cloud, yes it could be the cloud being very busy with the scans.

You could SSH into the cloud to turn off the scans… or
upon boot up and once you are able to access the dashboard,

  1. turn off cloud access
  2. turn off media switches like iTunes, DLNA
  3. reboot and wait for your cloud to settle

If you are setting a static IP, the DNS servers are usually pointed back to the router which is generally the safest. However you can point it to google DNS servers which are and which may or may not make your cloud faster. This is debatable since your router DNS servers may point to somewhere ISP internally and may be slower than Google DNS servers. On the latest cloud firmware, there is a button that you can click to set it to Google DNS.

This is what I’ve discovered over the years.

If your internet is down, i.e. router cannot connect to the internet but the router is still connected to your cable ISP server, all external DNS services will be unavailable… thus if you are pointed to Google DNS, your Cloud may lock up while accessing any files. Why? I am guessing that it uses the DNS services to confirm the data route. Yes this is exactly what happened to me. The first few seconds of a movie would play then it would lock up making me think that the Cloud hard drive is encountering errors. I can still see the directory, but just cannot access the files.

The other problem when using google DNS is when you don’t have internet, you won’t be able to resolve the address of your cloud with yourcloudname.local

Pointing the DNS server back to the router does seem to eliminate the problems. i.e. DNS servers

Also, putting a switch between your router and all your devices at home will prevent your home network going down when your router/internet goes down. For my pervious older router, when the internet goes down (at the ISP server point), my router would reboot causing my whole home network to go down. A switch separates the router from my home network.

Thus I could take out the router and still watch a movie streaming from my Cloud to my mac.

I have also added an Apple Airport Extreme to handle the AC Wifi on my home network, thus wifi is separate from my router/modem. The router/modem still handles the DHCP as well as handling the ports.

You can use google DNS or OpenDNS servers for the quicker responses but if you encounter problems, switch it back to

1 Like

right, many thanks. This will take me a few days to set up and soak test
before I can report back!

I’ll work through all that as time allows ! Meanwhile the intermediate switch does seem to fix the problem for me. I remembered an old SiteCom ethernet hub at the end of 20m of cable, occasionally used with the smart TV, so powered it up and shifted the physical WD disk down to the client side of that. The whole setup now works nominally and no more broadband problems thus far.
Knowing next to nothing about routing, the multi-day time-delayed interaction between the WD cloud and the fibre broadband access is puzzling, sounds a bit like a DoS attack on the router.