Router as the Master Browser

Is it advisable to set the Router as the master browser for network shares. If so, how does one do that.   

If so, I will turn off the Master Browser parameter in the registry on my windows 7 boxes. 

yes, it’s a great solutions to a common problem

how, depends on what router you have

Yes, it is a great idea to make the router the master browser.  Mine is; and fixes any issues with MB.  You do NOT need to get into Win 7 to do anything to turn it off/on/or sideways…

Some routers (e.g. WD routers) have an on/off control to make the router the MB.  On a WD router it is in the LAN settings.  In my Asus router, the router becomes the master browser by default when I “Enable DLNA Media Server”.  Not all routers are capable of this; usually only the more current ones can do this.

Go here for info about the MB, and download the free program to check on status of the MB anytime.

I have a Verizon supplied FIOS Actiontec Router and I don’t see any way to set it as the master browser.   

I’ve noticed that when I’ve set PC One as the master browser, I’ve seen other windows 7 boxes become the master browser even thought PC One is still the master browser still and has not been rebooted or shutdown.

To solve this, i’ve done registry edits on the ‘non master’ pc’s to insure that they do not have the option to become the master browser at Windows start up

Its not the most elegant solution but I’m hoping it helps for now since I never turn off my Master Browser PC - it has my RAID array and the majority of my FLAC/MP3 music files and AVI/MKV/VOB-ISO video

I don’t know for that router

WD routers have the option

asus routers with merlin firmware have the option

netgear, not sure

but for a generic actiontec provided by version, I sort of doubt they have the option

if they do it would be under smb server settings, and will usually require a thumbdrive plugged into the usb port as well

  asus routers with merlin firmware have the option

True, but my Asus RT-N66U can be set to be MB via the way I described above using Asus firmware.  BTW, this is a undocumented feature.

Having my router (or modem, for that matter) furnished by my ISP (Comcast in my case) is a major reason I don’t want their triple-play with phone service.  All I get is internet and cable TV; phone is still a landline service.  Comcast has the user guides for their equipment posted in an obscure place on their website, and same might be true for Verizon.

For routers with Tomato-firmware, you have to check the option “Master Browser” under “USB and NAS” / “File Sharing” / “Options”


Many main stream routers or anything delivered from a the major ISPs won’t allow you to set the master browser in the router, but if you have a router that will let you do so, by all means! 

This is a finnicky product and if you can’t set the master browser on your router then do it on the PC you want to stream from.

Number #1 issue with this product, networking, aka seeing  shares.  Good luck!

#1 issue with this product: frustrated users who can’t get it to work while others have no problems whatsoever with network shares.

Techflaws wrote:

#1 issue with this product: frustrated users who can’t get it to work while others have no problems whatsoever with network shares.

Im many cases I would agree, but there does seem to be some new issues with the SMP and firmware since lots of those folks have complained a lot lately.  Give 'em the benefit of the doubt.

That’s what I tought at first as well. But how come they still have problems when they do a rollback on 1.16.13?

   But how come they still have problems when they do a rollback…

Heck, if I knew, I could fix it for 'em!   :wink: 

Maybe the last firmware made some sort of irreversible change to unit before they reverted back.  This sort of thing has been documented in the past with a firmware for the Live Plus, and there was a warning from WD that we could check in, but we couldn’t check out sort-of-comment.  So what I did; I never moved ahead, and continue to stay to this day with a stable firmware for my Live Plus.

I only remember a warning not to downgrade from the 1.06.43 on the Live (not plus) to anything other than 1.06.15 which of course I tried anyway and it worked just fine with my usual resets.