Rollback Firmware, freezes WDTV


#1

Please could someone help, i got my WDTV, worked perfectly until i updated to the latest Firmware and the unit would not connect to the wireless network, i had to keep manually connecting, so i had decided to rollback the firmware to an earlier version. BUT when i downloaded the 3 files to a memory stick and put it in the WDTV Player, it found the software and rebooted the player, said it was updating the software, and started at 0%, but then it has frozen and will not load the software, tried powering down and then up, but it needs the memory stick with the firmware on, but when it tries to load it still freezes and we start over again.

Please can anyone help

many thanks


#2

Maybe you powered it down too soon. I upgraded the firmware in the same way you did, and it took very long till the ‘0%’ disappeared and it began to count. I’d recommend to leave it alone for some time. Powering down during a firmware update is very dangerous, and it should be done as a last measure only, if you are absolutely sure that it has failed. During a firmware update, devices often look like frozen because they are busy updating the firmware and don’t react on the remote or other inputs. It is because for the firmware update, the running firmware has to be stopped, so the unit is virtually dead during the update, except the percentage counter.


#3

Thanks for the message but I had left it for about 2 hours, and it was still on 0%, but luckily I have sent it back and have a new unit now, and all is good as long as I don’t upgrade the firmware!!!


#4

I have the same problem with mine. I had it at 0% for 2 days and finally I decided to power it off and tried to redo the upgrade with a different USB and it’s still at 0% after a week.  IS there anyway to fix it ? I bought mine last Janaury from Amazon and it’s past one year. For the last 11 months I hardly used it becasue of it’s slow and buggy interface. Any help to make it working will be greatly appreciated.


#5

well there is a solution, this is how i got over the problem, i went and bought the exact same unit from a shop then after a week i took it back with the old one, explained the upgrade firmware did not work and got my money back , i now have a unit with the original firmware and it works perfectly, as for it being slow, i have mine on a N Wireless link and i saved teh film as an AVI, and no problem at all, hope this helps