Robocopy Symlinks

when trying to copy Symlinks from Win server 2008 R2 to win server 2012 … the path to a network location (\server\folder)changed but still symlinks not copied correctly. file names and directories only copied, but the new symlinks don’t point to the correct path and the files are blank give us ( 0 bytes) .

I tried Robocopying to a different Windows system on the network (\AD\folder) with the same result, so it does not win server 2012 specific.

The command used (run as admin):
robocopy "F:\SAM\ASP\DCIM\WH\WAK\ " "\server\a\test " /s /sl

so how can I solve this problem and how can I solve a long path name issue for 1 source folder over 306 characters?


try to access the target with windows explorer to see you have full access or not ?
and I post a comment asking if they were created as symlinks or junctions ? but it’s not appeared


Haven’t used junctions in a while , everything appears as symlinks and No I don’t have problem when trying to access through explore. I’m able to partially create the symlinks with Robocopy, they just seem to be blank/ 0 Bytes files.


hmmm, did you know that robocopy can not copy symlinks from source to destination?
the only way to solve this issue is to use replication tools that can easily do this job and I recommend you AllWaySync or gs richcopy 360 , both can help you

1 Like

No, I didn’t no … I did a full search and saw some reviews for the 2 programs and found that I should use one of them, so I will try and feed you back .
… what about the long path names problem?

1 Like

both the two software are great solutions to long path names problem but I suggest gs richcopy 360

1 Like

Are you sue that they were created as symlinks and not junctions?

I have the same issue but from Windows server 2012 to NAS, can robocopy copy symlinks from windows server 2012 to NAS or it is generally can’t copy symlinks or should I use robocopy alternatives which recommended directly?

1 Like

Robocopy by default can not copy symlinks, just try any of the replication programs like gsrichcopy 360 or AllWaySync.

Thanks, Elana
Now I am using gs richcopy 360 enterprise, now I can copy symlinks easily and no long path issues appeared.


I saw your notification , but this post was helpful for me !

1 Like

Can Gs Richcopy 360 upload from our server to the Azure blob cloud ?

Hi Andoria
I use this tool as a backup/copy tool to our servers and our cloud and as an answer to your question, yes it can copy to Azure blob and the other major cloud providers like OneDrive SharePoint Online, AWS S3, and Google Drive.
and FYI it has an option to control the bandwidth while uploading to Azure Storage which not found on the other similar tools, so your bandwidth will not be consumed.
happy to help