RMA Problem:WD cannot find me in their records? But I can!


#1

Hi all

I have an My Book Studio Edition II 2 TB, 1 year old, suddenly the other day the one disk died. So I’m trying to make an online RMA, as I live in EU in a country that are allowed to make online RMAs. Not all are, apperently.

BUT, though I can login to my account fine, and see my 5 bought products and their serial numbers and ect., each time I try filling out an RMA, right after filling in my phone number and surname, this message comes up:

“We cannot find you in our records. If you have previously logged in to our site, please make sure that you use the same lastname and phone number to log in, and click the ‘Back’ button. Otherwise, use this form to create a new record.”

At this stage I’m already logged in, and I’m highly puzzled as to why this is happening? I’ve tried many times, and yes done the checking if I type my name and number correct, and I do. I’ve tried writing WD, they tell me that there’s another account with the same email but another phone number! How could this be possible? Surely their system only allow one email of a kind? They want me to phone them, but that’s going to cost me, and I’m not interested in that, when I have no problem, but the problem must be theirs.

Has anyone else encountered this problem? Does anyone have a solution?

Thank you all for reading

/Nina

EDIT! SOLVED! YAY! I’ve phoned WD, the problem is that when you update your own User Profile, it doesn’t update in their system. So since I created this account, I’ve had a new phone number, and their system didn’t know this. So that’s why they couldn’t see me in their system. It’s a bit of a silly error to be able to happen, one should think their system would just update along with one’s own update, but there you go. :smiley:


#2

Glad to here that the issue was resolved. Try contact WD when the issue happens by email. support@wdc.com

I’m guessing most people didnt reply to your post because they are prepared to handle product issues. But never the less thanks for sharing.