Ripping cds to NAS with windows media player


I have tried ripping cds directly to the NAS drive using windows media player, an error message appears saying that I do not have the correct permissions for doing so.

For now I am ripping to my hard drive and then copying to the NAS, help please


Have not tried this

You might wanna try mapping the drive and then give it a go

Thanks, the drive is both available via the network  as something like mybook Z , do you mean map it as a physical volume?

I have the same issue.  I can copy anything I want directly to the MBL, and the backups from my Windows 7 and Windows 8 machines are working, but in windows media player the shared music folder shows up as read only so I can’t rip a new CD directly to it.  I can rip to my hard drive and then move the files.

I have the same issue.  Is this something WD is going to look at?  As others have said, everything works except direct ripping to the MBL.  I am even able to add a folder to the drive in the Windows Media Player popup window used to select the drive for ripping, so I definitely have rights.  Please help.

I don’t use windows media player.

I have used both freemp3 & eac (exact audio c…) for ripping to the MBL without problems, but was done in win7.  Have win8 installed yesterday so no help there.

This one has me baffled and, so far, WD technical services has not been able to help.  One additional discovery, I can delete music files from MBL from within WMP.  So I can delete songs, I just can’t rip.  Any other thoughts?

This isn’t  a WD limitation. This is a limitation of Windows Media player not properly accessing a UNC share without some additional work. While it’s mapped on your computer as say Z: that’s simply a  pointer to a UNC path name. WMP expects to see windows permissions on that path and be able to access it and index it. It also tries to use impersonation for security. 

For a deep dive:

Pay particular attention to the “Configuring Remote Storage” section

The Jenny Craig version you can try this: