Ridiculously Slow transfer speeds - Windows10 to MyCloud - Help

I have just upgraded to Windows 10 from W7.
i was happy with how MyCloud worked with W7. Speeds were good.
i did a clean install of w10 and now speeds are ridiculously slow. like 200 KB/s. yes that’s kilobytes, occasionly i might hit 1MB/s but just for a few seconds. and the transfer continually stops and starts, like drops down to 0bytes/s for 20seconds at a time.
i use a program called freefilesync to run my backups, like i did on w7. a 250gb backup was going to take 42 days. wtf.
i haven’t changed any hardware.
i have green LED’s from PC to gigabyte switch.
green LED switch to MyCloud.
i have static IP’s
i tried a system reset
i tried setting Jumbo packets to 9k
i tried changing from auto negotiate to 1Gbps full duplex and back.
I tried a few other tips that i read about but speeds stay slow
w7 using the same program for backing up i was getting around 6-8MB/s for small files and 30-60MB/s for large files

What do i do to get back to the speeds i had with w7?

Hi there,

when you transfer information from file explorer,do you get the same speeds or is this from the software only.

Have you checked the sticky thread about Win10 issues, at the top of the forum?

yes have checked the w10 thread. i have read the whole thing and made any adjustments that were suggested. although there’s not much there that seems relevant to my problem.

yes same slow speeds through file explorer.

i tried copying some files through the wd desktop app as well and that is also so slow

also whatever i look at or do through dashboard takes minutes to refresh or reload

i thought it had fixed itself this morning. i started a copy and speeds were back to normal. but unfortunately it only lasted a minute and then it slowed to a crawl again.that was 6.5 hours ago. over that time it has copied about 6 GB only 244 to go. 24 days. guess thats better than to 42 i had the other day.

Why is this thing so slow with w10? how do i fix?

well its getting even slower now. i had 35 days remaining. then 370 days and now 2130 days.

what is going on?

Have you recently updated the firmware on the cloud?

its set to auto update. so its running v04.04.01-112
and i only switched to w10 less than a week ago.
so did the auto update happen at the same time?

I’m just speculating here, but if the firmware updated recently from OS1 to OS3, it could be rebuilding. See:


Has OS3 just recently been released? i couldn’t see a date on that support document you linked me to.
i have no idea how long ago my MyCloud was updated. I cannot see that information in the dashboard page.
Did i just fluke installing w10 at the same time as the MyCloud was updating?

I don’t recall the release date off hand, but it was released on the tail end of last year. My suggestion would be to let it sit for a day or so and than see if the issue resolved itself.

Release notes say 2015/10/21, which is about right. Auto-upgrades should have rolled out after that.

that was nearly 3 months ago. i only installed w10 less than a week ago.
surely it cant be still causing an issue from that long ago.
and i would have noticed on w7 if it was.

i guess there is no solution to this problem. i didn’t hear any ideas on how i could solve
i suspect that windows10 is partly (or likely mostly) to blame and that the mycloud does not work well with w10.

the mycloud was unusable in windows10 and i found many other problems and irritations with w10 as well.
so i clean installed w7 again. its good to be able to have use of the mycloud again. its good to be able transfer files at a reasonable speed again. its good that my computer will idle to sleep again. its good that, despite having a high end system, my computer is no longer sluggish. i can use Windows Media Center again. i even found that transferring files between internal hdd’s & ssd’s was slow in w10 and sometimes would stall during transfers.

it’s a shame as i liked the new look and interface of w10. maybe in the future i’ll try again after Microsoft release a service pack.

That is very slow, it will waste a lot of your time. Maybe a multi threaded file transferring software could help you in this case. In my case GS Richcopy 360 saved a lot of my time by speeding up the file transfer and backup process. Although it is a paid software and surely it will not cost you much comparing to the modifications you made in hardware. Hope it helps, thanks!