Revert My Cloud OS5 Back to OS3 (PR4100 & PR2100)

Yes, it is fairly simple, but it requires an SSH connection and a good copy of the rescue firmware. Otherwise, a UART connection must be used, and it’s a bit more complicated… and dangerous.

I can’t connect via SSH now - it gives an error.
Tell me where to get a copy of the rescue firmware?
How do I install it on a My Cloud?

Being your safe mode screen does come up, the wheel appears to spin without completing, I would assume the firmware being uploaded might be corrupt. I upgraded one of my EX2 Ultra’s to OS 5’s latest release and downgraded it just now to OS 3. I did get the spinning pinwheel for about 10 seconds prior to it starting the 1-100% and appearing to reboot. Once it appeared to be back up, I reloaded the webpage to see safemode again. Entered the same firmware and started the process a second time. I only got the pinwheel with no progress to 100% this time. As such, I unplugged the device for a couple seconds, and reapplied power. This booted into OS3. Once booted, I couldn’t loving, so I performed a 40 second reset on the device. The device rebooted, come up to a basic login. As such, I performed a factory reset, and then reinserted the original drives.

A definition of insanity: Trying the same thing over and over again; expecting different results.

Of course. . . . in the world of computers the answer is often “If it doesn’t work the first time. . . try it 5-10 more times”. Amazing how often that works.


What error is SSH giving you?

Note that different firmware versions have different SSH login details.
SSHD, SSH, and Root have been used for user names.
“blank” and Welc0me (or is it welc0me?) have also been used as passwords.

Login user for OS/3 and OS/5 is currently SSHD; but I know older devices/firmwares used root as SSH login user.


Random ideas:

Maybe you should get one or three OTHER OS3 firmware revisions. . and see if one works?

I am thinking that the rescue firmware for the Gen2 might not work on an EX2?

What if instead of trying to load OS3 EX2 firmware; one tries to load EX2 rescue firmware? (I know . . . a truly crazy idea from someone who knows absolutely nothing - - -use at your own risk.) I would imagine that if it works. . the unit will boot to rescue firmware and prompt to load new firmware. . . … .

Am I doing this right? I don’t really know what I am doing.

I just copied and paste

# Delete Linux kernel

mkdir /tmp/wdnas_kernel
mount /dev/mmcblk0p2 /tmp/wdnas_kernel
rm -f /tmp/wdnas_kernel/uImage

No, the first line is a comment, which I guess I should remove to prevent confusion. Also, you must execute the commands ONE LINE AT A TIME.

OK, now when entering: mkdir /tmp/wdnas_kernel, i’m getting this:

mkdir: cannot create directory ‘/tmp/wdnas_kernal’: File exists

Thank you, that worked. Another weird problem though. I can connect to my files through WD MyCloudPR4100 on my smart tv, but when using the My Cloud OS 3 android app or https://files.mycloud.com/ all I have is a WD Sync folder that is empty.

EDIT: Got it working, a security setting had reset.

Thanks for info. Got my My Cloud EX2 Ultra back to OS3 !

1 Like

Post by dswv42 [8][Dec 28] worked on my WDMyCloud Mirror Gen2. Only thing was the IP had changed when it came back up which I did not initially realise so installed “Advanced IP Scanner” to find the DHCP had allocated a different IP
Cheers

Worked straight and like a charm on my EX2U. Thanks a lot, was going to throw it through the window :smiley:

hy, can you explain how this works?

It’s simple. BIOS loads the bootloader, which looks for the Linux kernel on the default system partition. Deleting the Linux kernel from default system partition causes the bootloader to look for the Linux kernel on the fallback system rescue or “Safe Mode” partition.

Then there are the system config and config backup partitions, where the files are deleted to prevent potential My Cloud OS5 and My Cloud OS3 compatibility issues.

1 Like

ok it looks simple! thanks

Great Thanks.