Revert My Cloud OS5 Back to OS3 (EX4100, EX2100, EX2 Ultra & Mirror G2)

Many people have upgraded to My Cloud OS5, only to discover that it’s not suitable for their needs. WD claims that OS5 can’t be reverted, but that’s simply not true.

The “Safe Mode” firmware appears to be unchanged by OS5, so reverting back to OS3 can be accomplished by deleting the Linux kernel and system configuration files to trigger “Safe Mode” after rebooting the NAS. Deleting the Linux kernel may sound scary, but it’s exactly what the firmware does to trigger “Safe Mode” if it detects a problem.

An SSH connection is required, and this specific process of reverting back to OS3 only works on the My Cloud EX4100, My Cloud EX2100, My Cloud EX2 Ultra, or My Cloud Mirror Gen 2. It should NOT be attempted on any other NAS model. I’ve personally tested it on the My Cloud EX2 Ultra, but I don’t use the cloud-based services, so I don’t know how they might be affected.

USE AT YOUR OWN RISK.

The processs of reverting back to OS3 causes all users except “admin” to be lost, in addition to all system settings. Shares and data should remain unaffected. If the OS3 system configuration settings were saved to a file prior to upgrading to OS5, it should be possible to restore them via the dashboard.

Settings / Utilities / System Configuration / Import File

Create backups of your data, enable SSH access from the dashboard, then shut down the NAS and remove all hard drives, being certain to label each drive so it can be reinserted in the same bay it came from. This done as a precaution, where the drives can be reintegrated afterwards, with no data loss.

Download the My Cloud OS3 firmware for your NAS from the WD website, and save it to your computer. Be certain to verify that you have the correct My Cloud OS3 firmware bin file before proceeding.

Power on the NAS, then connect via SSH and log in (user: sshd) to get a Linux command prompt. An SSH client such as Putty is required. Execute the following commands, which will erase the Linux kernel and system settings, thus triggering the “Safe Mode” after a reboot, where new firmware may be uploaded. The commands must be executed ONE LINE AT A TIME , not all at once.

Erase Linux Kernel:

flash_eraseall /dev/mtd1

Erase Config Files:

umount -l /usr/local/config
ubidetach /dev/ubi_ctrl -m 5
flash_eraseall /dev/mtd5

WARNING: Carefully type the commands exactly as shown above, and DO NOT use the Linux dd command. Also, don’t touch /dev/mtd0 or /dev/mtd4. The following is is a list of the NAND partitions, for reference only.

/dev/mtd0 "U-Boot"
/dev/mtd1 "uImage"
/dev/mtd2 "uRamdisk"
/dev/mtd3 "image.cfs"
/dev/mtd4 "rescue fw"
/dev/mtd5 "config"
/dev/mtd6 "reserve1"
/dev/mtd7 "reserve2"

Simply power off the NAS, then power it on again, giving it time to finish booting into “Safe Mode”. Afterwards, connect to it via a web browser using the IP address. A “Safe Mode” firmware upload page should become available, where you can manually upload the OS3 firmware, as appropriate for your NAS.

WARNING: If you assigned a static IP address using the NAS, it won’t work because it was erased when the config files were deleted as part of the reversion process. The NAS will be assigned a new IP address by the router via DHCP. Log into the router and determine what the new IP address is, then use that to connect to the NAS with a browser. If you have trouble uploading new firmware, try a different browser.

_20201210_155321

After uploading the OS3 firmware, and the NAS has finished rebooting, power it off again and reinsert the hard drives. Power on the NAS, where all installed hard drives should now have a red status light after the boot process has finished. Connect to the dashboard via a web browser using the IP address and a “RAID Roaming” message should appear after logging in. Click “OK” to integrate the hard drives, without data loss. Afterwards, the status light for each installed hard drive should turn blue.

The process is now complete.

13 Likes

Just completed this procedure on my EX2 Ultra.
Worked a treat.
Thank you very much for this guide

Anyone try this with an EX4100? Having so many issues with 5 I would really like to give this a try but don’t want to brick my NAS.

My Cloud EX2 Ultra success back to OS3 :+1:

Than you for your manual! :sunglasses:

I would stay with the old OS3. WD said the OS5 is an upgrade. However, so far from what I see, it even has less features than the OS3 :roll_eyes:

https://support-en.wd.com/app/answers/detail/a_id/29389/h/p2/session/L3RpbWUvMTYxMDY4NDYxMi9nZW4vMTYxMDY4NDYxMi9zaWQvZlU0T1FlQ3NqMmZZbGxZWmJ1b2FpNXdHNWFMdGlXamE1R0hpcVduWG9XeDJZMDl3WmIzVkVveGU3QWs0dGNmT0xVSEpTblhBWGNlUDZUd1cxJTdFMXIyWExyWTlpejI2SXR5Z0d2THZGTDclN0Vxa1pUd3hJRlRYZHpPdyUyMSUyMQ==

Maybe you have to delete the old wd-device (with the static ip) in your router.

done that, thanks, but when I turn the NAS back on, it keeps telling:
IP address: disconnected

Without wanting to sound arrogant, it does truly sound like a networking problem
Quick ideas:

  1. Try with another router
  2. I cant remember if the Mac address is printed on the device, if so that’s another possible route in

Where are you seeing “Firmware update failed”? Is it on the LCD?

Are the network lights on the EX4100’s LAN port working?

I presume you did the obvious step of powering down (rebooting) the router and all other devices attached to the network. . . .

You could also try the 4 second and 40 second rests on the EX4100. You might get lucky.

When I can’t find a devices on a local network when helping people.
I use an Apple IOS app to net scan it is called Net analyzer in the Apple store.

I am sure there are same types for other phones or windows store for PC’s

I use fixed IP BUT as said NAS updates can change that.

( I hope that is the only problem and you get this solved )

Other steps are direct computer to NAS which is a good fall back on network problems.


The free light versions of the net tools should be ok just to see the IP address and device name.

Yes, MAC address is printed on the case, but how would it be of some use?

@Cordorb: Tried connecting NAS straight to PC, but it isn’t detected either

Yes.

If the lights are blinking on both the EX4100 and the router. . .then I think it is a fair assumption that they are talking to each other. There should be two lights. . . .solid means it is connected; blinking means connected and actively talking.

I honestly would not expect communication to work if you plug the NAS into a PC; unless the PC is configured to be a DHCP server. . . .which I don’t think I have ever looked into (that’s the router’s job)

So 4 and 40 second resets are used to “reset” the device and clear passwords and configuration.
There is a physical button somewhere on the device that allows you to do a 4 or 40 second reset if you hold it while powering on the device. A summary of the impacts are here: (This article applies if you trigger these resets from the device dashboard. . .but you get the gist. . .I couldn’t quickly find instructions for a power on reset.

How to restore a My Cloud EX4100 device to factory default settings (wd.com)

I suspect that there may be a glitch where the NAS is trying to use an IP address in a different subnet than the PC and/or router. . and that is causing an issue. (same subnet. . .first three sets of numbers in the ip address are the same: ex: 192.168.0.xxx). The resets should wipe out settings related to static IP address in the nas and “allow” the router to assign an IP address to the NAS.

Maybe I should ask “What do you mean it doesn’t appear on the network?”. How are you looking for it? I would start by looking for the NAS units IP address in the router dashboard. I would then use that IP address for SSH into the unit or to access the NAS dashboard from a web browser (it won’t be the normal OS/3 or OS/5 dashboard if the device is in a “recovery” state (i.e. running on the Rev 1.0 recovery firmware). I would not expect typing the device name in the web browser address bar to necessarily work. . . I would type the explicit IP address you get from the router’s dashboard.

Thanks, used this procedure for my My Cloud Ex2 Ultra, worked like a charm! I only use this NAS locally and don’t like to make it dependent of Internet access. Already thought I had to put it in the bin and buy a real NAS instead. You really saved me some money!

1 Like

THANK YOU, IT WORKS FOR ME!!!

But one addition:
If you have encrypting a RAID volume on a WD My Cloud Device, you have to add your password.
After this the old shares are available :innocent:

2 Likes

It worked fine for Mycloudex2Ultra!
Awesome post! :pray:

1 Like

So, I need to disable the static IP before running the commands, right?

Thanks for the lesson, but up there I still can make it.

THANK YOU, IT WORKED!

Didn’t changed anything about the static ip as it was configured on my router and not on the nas.

1 Like

then please stop replying: your answers are of no use to me. thanks