RetroPie working with CM3 and Media Stick


#1

If anyone was wondering I have having good luck running retropie on a CM3 and media stick.
I also have Kodi installed as a port and it streams great.


#2

That’s great- thanks for the info. How are you powering the stick- via power supply or using a USB port on the video monitor? For each use case (retropie and Kodi) what do you have plugged into the media stick’s two USB ports?


#3

At home I am powering the device from the USB port on the TV. It powers it just fine.
I have a wifi dongle plugged into one port and a USB Gamepad on another.

I brought it into work to show it off and used a 2a wall wart and otherwise the same setup.

I don’t need the wifi adapter when only using Retropie but I pretty much leave it in all the time.

Hardware:
Edimax EW-7811Un WiFi dongle.
DoTop Generic Super Nintendo Controller
22inch Raspberry Pi power cable with switch.
Generic 2a 5v wall wart.


#4

Hi,

Please could someone help. I have a Media Stick and a CM3 but seemingly nothing is working. I can get the Media Stick to flash that it’s in eMMC flash mode even when there is no CM3 present! When I run rpiboot my Ubuntu just sits there with “Waiting for BMC…” and the device seemingly never enumerates.

At the moment I have no idea if I have a faulty Media Stick, a faulty CM3, some combination of both or something else.

Any help would be much appreciated.

Thanks,


#5

I would check how you are connected to the module. I originally had a ton of trouble powering the module and sending the OS all via the USB.

I was using a rather long USB with a button on it that I typically use for the rPi’s. But that didn’t work for programing the CM3. I needed to use a very high quality cord less than 1 ft long.

WD recommends using a powered hub as an option as well.


#6

Brilliant, many thanks, I now have a running CM3 in a WD Media Stick! :slight_smile:

I found a short thick USB lead, which I naturally assumed that as it was thick must be of great quality! but still no joy. Then I dug out my old D-Link USB 2.0 powered hub that I knew could power a small town! and voila! life. I guess my no name USB 3 “powered” hub was not man enough for the job.


#7

Sensitive toy, but they are a lot of fun!