Retain Auto play when using multiple USB flash drives


Latest firmware as of May 1. 2013 


Generic USB flash with company logo

Sandisk Cruzer Facet USB flash drive

I have tried reboot, reset, factory defaults and 5 other devices.

I’m using WD TV live SMP for digital signage in our customers showroom’s.

The first 25 customers got a generic USB flash drive with company logo and WD TV Live box.

The autoplay function worked out great and I could just swap the USB drive with updated movies, restart the player, and the player started playing the new videos.

To keep up with the customers demand for this solution, I ordered 75 WD TV live boxes and instead of the custom made generic USB flashdrives, I ordered 75 Sandisk Cruzer Facet flasdrives and thought all was well.
I quickly discovered that I could not swap the Sandisk USB drives in the player. When I inserted a new Sandisk USB drive and restarted the media player, it would search for the old drive and after some time reported that the previously inserted drive was removed.

After a lot of trial and error I found, that the mediaplayer is reading the serial number of the USB flashdrive, when ever you setup autoplay.
With a partition tool, I changed serial numbers of the USB flash drives, so every one of Sandisk Cruzer now have the same serial number and voila, I was again able to retain autoplay functionality even though I swapped out the USB drive.

Just a thought, if you didn’t eject the generic USB drive correctly that could be the problem. Taking the USB out of the unit when it is off doesn’t eject the drive and leaves it’s ID in memory possibly.

So how come autoplay works for everyone else that hasn’t received an USB stick with WD logo and uses their own random ones?