Restore wd my cloud

I did apt-get update & dist-upgrade and now the web interface is bugged. 

How do i restore wd my cloud to the original state? :\

System Restore.

Unplug the device.

Hold the reset button in – don’t let go.

Plug the device in – conitnue holding the reset button for 40 seconds after power is applied.

Release the button – wait 10-15 minutes.

I did this and now my wd my cloud is with led white for atleast 10h. :S

Why did you apt-get update & dist-upgrade ?

i was testing… i tought it would be easy to get it back to the original state .

there is a way to delete the info inside?

Worked just fine for me. Many thanks!!!

Hi, 

I also have a white light for hours.

I tried to restore using the reset button.  How do I know if the reset procedure starts ?  Is there a LED code showind it has started ?

What does this procedure actually do ? Is it copying a backup original system partition on the used system partition ?  If it does, that should solve my problem.

any idea ?  My disk is only 1 week old, I don’t want to open it and loose warranty.

is there no USB boot sequence for restoring from USB image ?

Sorry but it is a bad move to run these commands on WDMyCloud. Most probably some of your system libraries has been replaced with non-64k page size memory debian packages (for v4 firmwares) or messed up the dependencies (for v3 firmwares), thus deem corrupted.

The system restore only revert settings. There’s no backup partition nor USB boot sequence to restore. You’ll need to dump a fresh rootfs image extracted from the original firmware, also means the need to open it up.