Resolved: WD EX2 works when connected directly to router, but will not connect when using Unmanaged Switch

Hello Everyone,

I have a WD MyCloud EX2 Ultra.

I bought a new 24-port Unmanaged Switch from Netgear (JFS524) where I have a line running from the router in to the switch and multiple client devices also connected. Every other device is working fine except the EX2.

The power LED is RED (solid) and I have no network access to the EX2. I have given it a static IP address of and pings are failing also. No activity light on that port on the switch.

I’ve connected an ethernet straight from the router to the EX2 and that works perfectly!

I’ve tried changing from a static IP to DHCP and still no joy. Red power LED. I’ve even tried different cables.

Every other device connected to the switch (incl Desktops and a Time Capsule) all work perfectly fine. But the EX2 is no bueno. I’ve also tried accessing the EX2 from different devices and no joy either.

Any further suggestions would be appreciated.

I’ve since resolved this issue. In the Settings, in the Network section, of the EX2, I had Link Speed set to “1000”. I changed this to AUTO and this solved the problem.

Yep, that’d make sense since the JFS524 is a 100-meg switch and can’t do Gig.

As inexpensive as Gigabit-capable switches are, you’d get a significant performance boost by replacing that switch.

Yeah it definitely makes sense to me now. A good learning experience.

Yeah I’ve noticed the performance is lower when connected with the switch.

I’m looking to return it to Amazon and replace it with a gigabit switch.