[Resolved] Problems with G-RAID Thunderbolt 2 8TB on Macbook Pro

Hi there,

I am Epsilon, from Adelaide, South Australia.

This week I purchased a brand new G-RAID Thunderbolt 2 / USB 3.0 8TB external unit from the Adelaide Apple Store and have had nothing but trouble with it. The unit model is 0G04480.

To start with, this is my setup:

Macbook Pro (late 2013) with 1TB SSD and El Capitan 10.11.6 installed. Connected to one of the Macbook Pro thunderbolt ports is a 27" Apple Thunderbolt Display. A 30" Dell Monitor with Apple Dual DVI-D to Mini display port adapter, connected to the other thunderbolt port.

Connected to the 27" Thunderbolt monitor ports is: Seagate 2TB USB 3.0 Time Machine HD (bus powered), 5TB Seagate USB 3.0 HD (external powered), and wired Ethernet connection.

Connected to one of the USB ports on the MacBook Pro is a Powered USB 2.0 hub servicing iPod/iPhone docks and the USB power cable needed for the Apple DVI-D to mini display port adapter (connecting direct to the Mac removes any remaining ports so it is done this way to leave one USB 3.0 port on the Macbook Pro free for other uses like USB 3.0 flash drives, etc.

Ok, so I bought the G-RAID 8TB to replace the troublesome 5TB seagate HD which struggles to maintain 25MB/s copying files. It currently has around 3TB of data on it which I want to transfer to the G-RAID.

I placed the G-RAID on a flat table with plenty of space around it. At first I tried connecting the G-RAID 8TB to the thunderbolt connector port on the Macbook Pro, replacing the 30" monitor display port connector. I found that if I passed through the display port on the 30" to the G-RAID it wouldn’t display. Having now read this forum I understand that it can’t do this because it is display port not thunderbolt. However on power on the drive didn’t appear on the Mac desktop at all, even though it was directly connected to the thunderbolt port on the Macbook Pro.

Having removed the 30" monitor connection completely now, with the G-RAID being the only thing connected to the thunderbolt port on the Macbook Pro, it still wouldn’t mount. It was not visible in Disk Utility either.

I then tried connecting the G-RAID thunderbolt port to the spare pass through thunderbolt port on the 27" thunderbolt display. It still wouldn’t mount.

I tried changing the included thunderbolt cable in the box for a brand new Apple thunderbolt cable in both configurations (27" display and directly connected to the Macbook Pro) and same result - it didn’t mount. (I tried power cycling the unit a few times as well with no effect).

Giving up on the thunderbolt connection, next I tried connecting the G-RAID to the USB 3.0 port on the Macbook Pro using the included USB3.0 cable in the package. When I did this, the drive appeared for the first time.

On my Mac I run Pathfinder in place of Finder, so I used pathfinder to copy files from the 5TB seagate drive to the 8TB seagate drive. After only 20 minutes or so of copying the G-RAID drive would suddenly eject by itself with no warning, in the middle of the copying operation.

I then power cycled the drive to get it to mount again, and tried copying again with the same result every time. It would auto dismount itself more quickly after about 10 minutes.

I then tried using Finder instead of Pathfinder but saw the exact same result - auto dismount after around 10 minutes.

I suspected over heating at this point, so I powered down and removed the hard drives from the G-RAID and confirmed they were boiling hot. I suspected that they were dismounting due to overheating.

To test my theory I pointed a fan straight at the front of the G-RAID unit with the front door open, and powered on and tried the copying again. Now the copying was working as expected, and has been running for many hours now stable as long as a fan was pointed straight at it.

It seems to me that this unit has a fundamental design flaw in mounting the hard disks horizontally on top of each other instead of vertically, meaning all the heat is trapped in the case, which has no vent holes except at the front and a small fan at the back. From what I can feel the worst of the heat was at the rear of the hard disks in the case.

Clearly the fan at the back (which is running - I checked) is unable to keep the G-RAID drives cool enough to operate in normal ambient temperature conditions. The temperature in the room here is around 14C this week so it is perfect for hard disk operation and should not present any issues.

I am totally frustrated with investing AUD$1000 to buy a G-RAID drive that can’t run in thunderbolt mode at all, and can’t run reliably in USB 3.0 mode unless a big fan is pointed at it whenever it is in use.

I am most likely going to return the unit this weekend to Apple unless someone here can point out where I am going wrong. Thanks for reading this far and hopefully this can be sorted out simply.


Hi All,

As an update to close this out I was kindly contacted during the week by a support person from G-Technology (WD?) who suggested some things, but unfortunately although it helped with getting the thunderbolt to mount, the auto dismounting and overheating problems persisted with red light “G” appearing on power on.

I returned the G-RAID unit on saturday to the Apple store and got a replacement G-RAID. Interesting to note that in the week and a bit since I bought the G-RAID Apple increased the cost of it by AUD$100. Fortunately for me they honoured the original price I paid for it, but wow - anyway.

The new replacement G-RAID unit seems to work ok so far. I transferred my data to it no problems overnight and seems to be running well and not dismounting by itself. Will keep an eye on it.

I also took the opportunity to upgrade to MacOS Sierra and it is working fine under that as well.