[Resolved] Location is not available

Greetings.

Device: WD My Passport Ultra, 2 GB
Model number: Model Number: WD My Passport 259D

When I try to open this drive I get an error message:

Location is not available
D:\ is not accessible.
The parameter is incorrect

I tried changing the name of the drive from “D” to “K”, but still get the same error message:

Location is not available
K:\ is not accessible.
The parameter is incorrect

I’ve run the WD Drive Utilities -> Quick Drive Test and get “Pass”
Also the Complete Drive Test and, again, get “Pass”

I’ve also run the Western Digital LifeGuard Diagnostic app and get “Pass” for both “Quick Test” and “Extended Test”.

I’m able to scan the device with Norton.
Norton scanned all 17,000 files. No viruses or other problems were detected.

So, Norton is able to get into the drive and the WD diagnostic tools are able to get into it.
But I can’t.

I’ve tried a few other things, but to no avail.

Any advice would be greatly appreciated.

Thanks.

Best Wishes,

Prodos
Melbourne, Australia

I’ve never had this problem with any WD external hard drive … so i googled it

Seems to be corruption or bad sectors which is contrary to what WD Drive Utilities is reporting

1 Like

Thanks for your thoughts & for taking the time to GOOGLE the issue.

Yes, it does all seem a bit weird.

I would tend to trust the WD tools – which are specialised – more than the Windows tools – which are for applications in general.

And I’ve found WD products to be very robust and reliable.

Maybe Windows is misreading something?
Or maybe there’s some sort of “permissions” issue that’s suddenly happened?
I don’t know.

I’ve clicked everything I can think of to try and get this drive accessible again,
but I’m not very technical-minded … so it’s all a bit confusing.

Best Wishes,

Prodos

As shown, above, the WD Drive Utilities could not find any problem.

Yet I’m still unable to open this external drive.

Weird!

Update:

In case the problem is simply the cable from the external drive to the laptop, I’ve ordered a replacement from an eBay seller. Delivery is due Friday.

I’ve also opened a support ticket with WD.

I’ve finally regained access to my external hard drive!

There are probably other ways to do this, but here are the steps I took – some of which may not have been necessary, and some of which could probably be done more efficiently.

Essentially, I added another user called “Everyone”.

I went to my Device Manager and saw that WD My Passport 259D USB Device was indeed listed.

Right-clicked on the the listing … selected “Properties” … then selected the tab “Volume”.

No “Volumes” were showing.
Clicked the button named “Populate”.
Now “Volumes” became visible and various data about the drive became visible.
In the window at the bottom, called “Volume” (which provided other details) I clicked on “My Passport (K:)”

Note: I had earlier renamed my external hard drive from “D” to “K” because some articles I’d read
suggested that this can sometimes fix the kind of error message I’d been getting. It’s possible in my case that this was unnecessary, but I don’t know for sure.

I clicked on “My Passport (K:)” and then clicked the button titled “Properties” then clicked the tab titled “Security”.

The top panel under this tab is called “Group or user names”.

There were two items within this panel.
One was “SYSTEM” … The other was “Administrators (followed by other letters)”

Clicking on either of these displays the “permissions” that each has.

I don’t think it actually matters which one is clicked.

The point to note is that there is a button under this panel titled “Edit”.
I clicked on that.

This popped up another panel called “Security”
Under the window called “Group or user names:” I clicked the button titled “Add”.

This brought up a panel called Select Users or Groups.
This panel has an area at the bottom titled “Enter the object names to select (examples)”.

I typed in “Everyone” and then – if I recall correctly – I think I then clicked the adjacent button titled “Check Names”

At around this point somewhere … I don’t remember exactly & don’t want to tamper with it for now … the new user or group titled “Everyone” was accepted and a list of permissions was presented.
I think I checked/ticked them all and lo and behold, my external drive was now accessible.

The above notes are not meant as instructions.
They are merely my best recollection of what I did and the fact that I ended up regaining access to my external hard drive.

I’m sure the way I went about it was incredibly convoluted and someone more knowledgeable could provide a more direct and logical process/pathway for solving the problem.

Why my WD My Passport Ultra suddenly stopped allowing me access remains a mystery.

Was the problem actually caused by my computer?

Maybe, but I tried to access the external hard drive from both my Windows 10 laptops and they both brought up the same error message. The external hard drive was inaccessible from both the laptops.

If anyone reading this has a theory about what may have caused the problem in the first place, I’d be very interested to read it.

:sunglasses:

Best Wishes,

Prodos
Melbourne, Australia

Hi Prodos, Thank you for all your detailed step-by-step information. It helped me solve the problem and now I have access to my Drive. It has more than 10 years of data and because of you I was able to get them back.

Yesterday when I was copying the files from my iPhone to this Drive, at some point it gave me warning that My Passport may have Error and it can attempt to Repair it, I clicked on Yes. After a while it just showed D:\ and NTFS and it was not accessible.

Now everything looks good. Thanks…

1 Like

This solution helped me, too. Much appreciated.