Resetting EX2 using reset button is not working - need to reset!

I’ve recently been wanting to log onto the MyCloud interface to adjust some settings, and discovered that the password that I thought I had written down correctly seems to be incorrect, for reasons unknown. I found through an online support search that the network settings (incl. login password) could be simply changed by holding down the reset button on the rear of the device for 5 seconds, at which time the device would reboot, and I inferred would then be ready to reconfigure.

I’ve now held down the reset button on several occassions, and while it does look like the drive reboots (the power light flashes for a while during this time), it doesn’t give me any option to reconfigure the drive once running again. If I run the setup software, all parameters are already setup as before, and I still am given the normal login screen when trying to login to MyCloud. It’s still accessible in the network window, and I can still access my files, but I really, really need to log into the MyCloud interface to tweak settings, which I can’t without resetting my password.

Does anyone have thoughts on this?


You need to press and hold the button for 40 seconds during boot up, then release the button and wait some time (approx. 4 Minutes) until the reboot has finsihed.


This worked - thanks! It’d be great if the instructions in the link could be updated to show the need to hold the button for 40 seconds, instead of 5…

5 seconds = Reset
40 seconds = Reset to Factory Defaults

but yes, you are right, this is missing.


i also recently have the same issues.
Thank you very much !

1 Like

FYI: Holding it too long may induce permanent and irreversible magnetization to the drives.
It’s happened to me and I would up returning & exchanged the unit at Bestbuy.

Maybe I pushed it too hard with the paperclip, and the button got permanently jammed. I’d use a soft object like a cuetip.

if i hold the reset botton for 5 seconds it will reset my admin password to default?? withouth formating or erasing my files inside the NAs?

This option also DOES NOT WORK. I spent more than few weeks with technical support trying do all sort of things to windows 10 software, resetting many times and the answer is NO. The wd cloud suppose to revert to “admin” after 40 sec reset, but always display the my username. In my case I knew the password so it didn’t recognise that either.
Shear waste of time, going round and round. Technical support have no idea how to correct and see lot of users here have the same problem.

I was able to solve my reset problem by watching the following video;