Reset root password on MBWE white light


#1

I logged into my MyBook WDH1NC10000 via puTTY as root, using the standard password “welc0me”, then changed the password to “root”, 'coz that’s what I used to do on my UNIX systems 20 years ago. Then I decided that an empty password would make things easier (I have since left the world of geekidom), so tried that. Then I tried logging in again with the blank password and of course it didn’t work, as has already been documented on various forums. So my question is whether or not there is anyway to reset the root password, other than by performing a factory reset. I have a hunch that I might just have to wait for the next firmware upgrade, but if anyone has any thoughts, I would be grateful.


#2

Pressing the recovery button while powering up the device resets the admin user
name and password to default without erasing shared folders or volumes. The
recovery button also resets network configuration to DHCP (obtain an IP address
automatically). Follow the instructions below to reset the device using the recovery
button.

  1. Turn off the device and disconnect all cables from the unit.
  2. Insert a paperclip or narrow tipped pen into the recovery slot on the back of the
    unit. Press and hold down the recovery button.
  3. While continuing to hold down the recovery button, connect the power cable to
    the back of the unit.
  4. Hold the recovery button down until 10 seconds after the power/activity LED
    lights on the front of the device, then release the button. The unit may take up to
    three minutes to boot up completely.
    Note: The default user name is admin and the default password is 123456.

#3

Hi D-U-D-E, my problem is not with the admin password, which I have already reset, hoping it might also reset the root password, but the password of root in the BusyBox mini Linux Operating System.

It’s not a big deal and does not affect the operation of the unit, but it is simply a little frustrating to have got so deep into the system and then shut myself out.

Eli