Rescuing data from an old WD My Book World Edition 1.5TB


a coworker asked me to try to recover data from his old WD My Book World Edition 1.5TB. The device itself is dead, power supply has failed and so did the motherboard. And one of the two disks stopped working too, but the other one, 750GB WD7500AAKS seems to be working fine and I can see partitions on the drive.

These are the partitions:

Disk /dev/sdc: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00010907

Device Boot Start End Blocks Id System
/dev/sdc1 48195 5927984 2939895 fd Linux raid autodetect
/dev/sdc2 5927985 6136829 104422+ fd Linux raid autodetect
/dev/sdc3 6136830 8112824 987997+ fd Linux raid autodetect
/dev/sdc4 8112825 1465144064 728515620 fd Linux raid autodetect

If I run gparted, I see that first and third partitions are ext3, the second one is swap, but the interesting one, the fourth partition … has an unknown file system. I googled … a lot, found out that sometimes these partitions are in XFS file system. This one doesn’t seem to be:

xfs_check: /dev/sdc4 is not a valid XFS filesystem (unexpected SB magic number 0x00000000)
xfs_check: WARNING - filesystem uses v1 dirs,limited functionality provided.
xfs_check: read failed: Invalid argument
cache_node_purge: refcount was 1, not zero (node=0x1c6fed0)
xfs_check: cannot read root inode (22)
bad superblock magic number 0, giving up

I even tried R-Studio and there also was the file system on the fourth partition “unknown”. UFS Explorer and NAS Data Recovery didn’t help either. :-/

Any suggestions what to do? Considering the hard disk seems to function properly it shouldn’t be hard to copy data from that partition, but how [deleted] do I mount that? :slight_smile:

Hi andraz, I recommend you to contact any of the data recovery companies on the WD support page. There are also some threads on the forum with some advice on how to recover your data. 

Data recovery partners

WD Community Post

1 Like

Well, here’s what was the problem … PEBKAC (Problem Exists Between Keyboard And Chair).

If one asks you to try to recover some data from a supposedly RAID1 array and you see an unknown file system … stop wasting your time figuring out what exotic file system could that be … instead, browse that perfectly mountable ext3 partition, where /etc folder resides and have a look at mdadm.conf file. You know, just to check if the device wasn’t configured by a person dump enough to use “linear” instead of a mirror. The device I was looking at was. 

DEVICE partitions
ARRAY /dev/md1 level=raid1 num-devices=2 UUID=448b6d48:e61b8c2c:d8164f57:15f1a403
ARRAY /dev/md2 level=raid1 num-devices=2 UUID=e82637b4:1e4b8b82:04b60160:9e819908
ARRAY /dev/md3 level=raid1 num-devices=2 UUID=a433ab64:9077fd6c:b80fa81e:e364f901
ARRAY /dev/md4 level=linear num-devices=2 UUID=4e119873:258a8cf4:1688b5b1:b508a7a4

Then you can tell the happy owner of the device that, sadly, he/she needs both two disks functional. Well, at least the swap partition is mirrored. :slight_smile: 1.5TB does sound better than 750GB, but, well, without mirroring. :wink: