Rescanning the network


#1

How can I make a complete new scan of my network? I have tried to reser the unit for 10sec but it seems like the unit retrieves old data instead of doing a new scan.

The problem is that I have 4 Netgear ReadyNAS NV+ on my network (as media servers) and everytime I remove a file I naturally want the WD live HD not to see this “old” file anymore. But the old “files” are still there in the list, clicking on it will only make the screen black (naturally, there is no file there anymore) But why doesn’t the WD live notice that the files has been deleted and act accordingly? On my other computers, the file is gone.

Rescanned one of the NAS and now the files that wasn’t there is gone but also about 75% of the files that are still there isn’t shown in the list by the WD Live HD.

Also, one of the NAS has disappeared completely after a rescan on that NAS. Very annoying…

How can I make the device “think” it’s just out of the box?


#2

Welcome to the forums.

How are you connecting?  Via network shares I don’t have any problems with my NAS when I add or remove files – I don’t even need to reset things (just back out and reconnect).  I would highly recommend network shares anyway, as media servers are unreliable (IMHO).


#3

The WDTV Live caches directory contents.    To get an update, just back up one Menu level and re-descend into it.  

One can tell that the firmware writers weren’t expecting the users to do things like that, because if they were, it’d say “File no longer available.” or something, and immediately refresh.  But it doesn’t… :wink:

A minor annoyance, perhaps, but easy to work around.


#4

Thanks for the quick answers.

I have done everything short of throwing the **bleep** thing into a concrete wall…

Whatever I do, go back one step or turn it off, disconnect everything and turn it on again, nothing changes.

However, it sounds interresting using shares instead of media servers.

How does it work? I have tried to “log in” on the shares but it doesn’t find any files.

I have a Netgear 9150 media player also and it works great, so the NAS shouldn’t be the problem.


#5

I’m sorry, I didn’t catch that your NAS was set up as a Media Server.

Apparently the NAS is sending an outdated listing.   The problem is with the NAS, not the WDTV.   It’s only displaying what it’s told to display by the Media Server.

I’d wager that if you rebooted your NAS, then re-browsed to it via the WDTV, it’d be different results.

I don’t know anything about your model, but I’ve noticed on my Linsys E3000s (which can be Media Servers) there’s a configuration item for RESCAN INTERVAL or something like that.   I’m guessing it fixes exactly what you’re describing when IT is the server.   

You’ll need to consult the docs for your NAS to see if it can do that.


#6

Update: Yes, the E3000’s have an “Auto-Scan” setting.   The MINIMUM time is two hours, or unless I log into the E3000 and tell it to scan now.


#7

benkebona wrote:

However, it sounds interresting using shares instead of media servers.

How does it work? I have tried to “log in” on the shares but it doesn’t find any files.

 

Yeah, as Tony says, it’s your NAS not the Live.  Still another reason not to use media servers.

Net shares is dead solid simple – your NAS ought to be able to share the directories (and should have docs to tell you how to do it).  On my NAS it’s just a matter of running a simple browser program and setting the shares up.  I’d recommend you share to “everyone” and turn off passwords on them.