Requested help RE: FW Release 3.04.01 (3/5/14)

This thread created off of response received at due to thread clutter.

Thank you for wanting to provide some support. Here is some review.


This is my original text…

HawkeWynde wrote:

I have purchased the MyCloud in the past couple of weeks and have had two firmware updates. Each has done the same thing resulting in no longer being able to access my router.

Router IP is X.X.X.X  (I use an IP I chose rather than the standard 192.168.x.x)

MyCloud IP is X.X.X.Y

With the last FW update, I had to wipe out my router, reset it to factory settings and open/unsecure and then go in and reconfigure it, manually. It appears I may have to do this again unless there is a fix that can be eaily performed.

Before the update, I could access the router at X.X.X.X and the MyCloud at X.X.X.Y, respectively. Now, X.X.X.X goes to the MyCloud dashboard and X.X.X.Y also goes to the MyCloud dashboard.

The IPs are obtained dynamically through the router, and the FW overtook X.X.X.X, the main router IP.

A fix would be greatly appreciated. Thank you.


I followed these volunteered steps…

You could try to disconnect the network cable between MyCloud and your router.

Then power off the router for about 10 sec. and reconnect.

It might also be necessary to reboot your PC.

After that hopefully your router and PC should again be ok?

If so, you can disconnect power of MyCloud for 15 seconds, reconnect its network cable to the router and then re-power MyCloud. Hopefully it will take a fresh IP from your router without disturbing the PC.


This was the result…

Hello. Thank you for the ideas. I performed them all and they ultimately have no effect.

Once all was off and the router power cycled, the PC was rebooted and X.X.X.X tested, the router page came up normally. After the Cloud drive was restarted and attached, it again, took over X.X.X.X and still operates on both X.X.X.X and X.X.X.Y.

What software solution exists? Software caused the problem, naturally there is a softare solution. Any idea where it can be found?

Thank  you.


The following response is from TonyPH12345 from the other thread…

HawkeWynde, can you start your own thread on this problem? I’d like to try to help, but this thread is too crowded,


As a test, disconnecting the cloud drive’s power and network cable returns the network to normal and being able to access the router at X.X.X.X. Plugging the cloud drive back in returns its control of both its own IP X.X.X.Y as well as the router IP of X.X.X.X.

There have been ideas of rolling back the FW to a previous version such as, yet I suffered the same thing with the most recent previous release. If it’s recommnded I try the OOTB version, I would just need the version number as the network was not overtaken by the OOTB version (Out Of The Box).

As I have MS, getting behind hardware for physical cutoffs and replugs isn’t overly comfortable for my head. it gets easily bobble-head-like when tilting it and such. I’d like a gauranteed software solution IAAP (If At All Possible).

Thank  you.

Replies from TonyPH12345 and WD staff are appreciated. Thank you.

 Does the IP you created fall in the range designated for private internal IP addresses?

  • IP addresses: –
  • IP addresses: –
  • IP addresses: –

 If not I wonder if that might cause some issues.

Hawke, if you can reproduce this issue reliably, do this:

Shut down the My Cloud.

open a CMD prompt window on your PC AS ADMINISTRATOR    (Click START, in the search box type “cmd” and wait until “cmd.exe” appears in the list.   RIGHT-Click cmd.exe and select “Run as administrator” and issue this command in that window:

arp -d *

Now, log into your router using the normal way you’re doing.

Now in the CMD window, enter

arp -a

Copy and paste the results to this thread.

Now turn on the My Cloud

Do what you’re doing to get the “wrong” results.

do the command

arp -a 

again, and copy/paste the results again to this thread.

First, what is the make and model of router you have?


Have you checked the router user manual to see if it can provide what to do?


For me I would have stuck with the addresses provided by my internet provider and those through DHCP.


My first troubleshooting step would be to unplug the power to my router at the router for a couple of minutes and then plug it back in and see what happens.

Ok, here are the Before results.

Interface: — 0xd
Internet Address Physical Address Type 00-24-2b-7f-5c-20 dynamic b8-3e-59-0e-b6-bd dynamic c8-d7-19-37-c9-0d dynamic 00-22-4d-9d-8a-c5 dynamic ff-ff-ff-ff-ff-ff static 01-00-5e-00-00-02 static 01-00-5e-00-00-16 static 01-00-5e-00-00-fb static 01-00-5e-00-00-fc static 01-00-5e-00-00-fd static 01-00-5e-7f-ff-fa static ff-ff-ff-ff-ff-ff static

Here are the After results…

Interface: — 0xd
Internet Address Physical Address Type 00-24-2b-7f-5c-20 dynamic b8-3e-59-0e-b6-bd dynamic 00-90-a9-3a-69-ed dynamic c8-d7-19-37-c9-0d dynamic 00-22-4d-9d-8a-c5 dynamic ff-ff-ff-ff-ff-ff static 01-00-5e-00-00-02 static 01-00-5e-00-00-16 static 01-00-5e-00-00-fb static 01-00-5e-00-00-fc static 01-00-5e-00-00-fd static 01-00-5e-7f-ff-fa static ff-ff-ff-ff-ff-ff static

My aplogies for the delay, very busy with the family, today.

Router IP ends in 42, which is taken over by the Cloud unit assigned to 30. Both IPs go to the cloud drive.

I really appreciate your assistance, Tony.

Those are some weird addresses!

But no, technically, the WD is NOT taking over the router’s address.

Your Router, by itself shows: c8-d7-19-37-c9-0d

When you turn on the cloud, the router doesn’t change – it’s still


Your cloud appears by itself: 00-90-a9-3a-69-ed

So it appears that your router must be forwarding the packets to the Cloud instead of listening to them itself for some reason.   I’ve never seen that happen before…  It almost looks as if your router is forwarding UPnP requests on your LAN as well as your WAN.    A router should *NEVER* do that.   

What kind of router do you have?

Linksys EA3500

Yeah, I thought it was acting strange, both with UPnP on and off. Perhaps if I made everything static, perhaps? Yes, the IPs are weird, to say the least, little personal reasons for using them aside from the dynamic assignments of the last numbers, of ocourse.

Hmmm.   Linksys has been around for a long time, and I can’t imagine them screwing up something that basic.

So when you say UPnP on or off, you’ve actually tried disabling completely on the EA3500?

Also, have you tried DISABLING Cloud Access on the My Cloud setup?

IMO if you aren’t using one of the standard private ip addresses in your network you are asking for trouble.

try using one of the standard private ip addresses and your problems will probably go away.

The only problem with using non-private addresses in a private setting is that someone on the internet may be using those same addresses in a PUBLIC setting – and you won’t be able to reach them.

Other than that, it’s pretty much an arbitrary choice what to use behind a NAT’ed router.

1 Like

I haven’t disabled cloud access during setup as I want my extended family access to an archive of a digital conversion of my parents’ old media. I could certainly tdo a general cloud access disable and then give certain users cloud access (I haven’t set them up as of yet, anyhow).

I’m just trying to see if that has any bearing on the issue – if it doesn’t “fix” it, then turn it back on.

If it does fix it, it might point to one issue or another.

No worries. :slight_smile:

Ok, I shut off Remote access and now the IPs operate normally. I’m assuming that with Remote Access (as it’s somewhat titled) shut off, my family members can’t gain access to the content?

Shutting off the cloud access fixes the issue. I do need to have the cloud access working and not redirect the router IP to the cloud drive IP. Any idea what the fix would be?

Ok, this is a WAG… (Wild-A$$ guess) just as a trial, try using private IPs on your router, cloud, and PC as gewilli suggested. If it works, I’ll eat my words (and some crow).

WAG successful. :smiley:

Apologies for the delay, I just had the opportunity to test the IP reservations while troubleshooting my son’s laptop.

Thnk you very much for the level of assistance, it was very helpful!

Awesome…  I guess your router has issues with UPnP mixed with “real” addresses on the inside of the network.

I spoke too soon. It took over the router IP again. I suppose I’ll just have to play with it.