Repository with software worked on v4 firmware

Fox_exe- If your 64k packages for wheezy are still updated, would you or anyone be able to include the Zram module for kernel 3.2 for download right here or in your 64k wheezy repository? That would be amazing.

Hi there, can you please give me specific instructions step by step on how to install Transmission on my 1st gen WD MyCloud, including any chroot installs. I’ve tried a few times now but it keeps failing at one section and I have to reload my firmware. I’m sure I’m missing a step somewhere…


I’ve just done that myself last weekend so will try to post up what I think I had to do, first time I’ve used SSH or Linux so apologies if I miss anything:

Installed CHRoot per the below:


1. Upload to “Public” folder

2. Enable “SSH Access” in web interace (copy password. User - root)

3. Connect via SSH to wdmc (Use PuTTY tool) and run (type) this:

chmod a+x /shares/Public/

After installing run this for enable autostart:

/DataVolume/debian/ install

To update anything I had to do this to get DNS servers (at system, not chroot):

cp /etc/resolv.conf /DataVolume/debian/etc/


Go inside chroot:

chroot /DataVolume/debian /bin/bash

Exit chroot


Then followed some of the instructions here:

Inside chroot:

apt-get install transmission-daemon

Stop Transmission so you can edit the settings.json file

/etc/init.d/transmission-daemon stop
Disable the dashboard login
sed -i ‘s/“rpc-authentication-required”: true,/“rpc-authentication-required”: false,/g’ /etc/transmission-daemon/settings.json
Disable the RPC whitelist so you can access the Transmission GUI
sed -i ‘s/“rpc-whitelist-enabled”: true,/“rpc-whitelist-enabled”: false,/g’ /etc/transmission
Start Transmission
/etc/init.d/transmission-daemon start

Login to the Transmission GUI
your mycloud ip or network name :9091
Click the wrench icon on the bottom left
In the Download To box enter /DataVolume/shares/Public/Transmission or any share on your MyCloud

Check out the inks for full details but I think the above is what got me there.


Thanks so much, will give it a try!


Any chance to add btsync or resilo to repo? Or any suggestion to add autoboot script for fw 4+?

Add whatever boot stuff you need to user-start

/CacheVolume/user-start, or the symbolic link /etc/rc2.d/S98user-start

For example:


Any plans to add the latest minidlna 1.2.0 ? I’m sick of the rigamarole downloading from nazar’s server. :roll_eyes:

Is Aria2 still supported? I can’t find it on the repo link at the top and I get the below when trying to install it:

Chroot:~# apt-get install aria2
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package aria2

If you want to install LEMP (Nginx, php5, Mysql), you can find all needed 64k .deb packages
HERE, and also ask for another packages

Hi @Fox_exe ,

im wondering does the ps3netsrv still working for WD MYcloud 3TB (v04.05.00-315)
if yes where i can find it. i just got my ps3 and would love if can load games from my WD MYCloud.

Thanks in advance

Please assist to solve. The installation fails. Thank you.

Chroot:~# apt-get install transmission-daemon
Reading package lists… Done
Building dependency tree
Reading state information… Done
transmission-daemon is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
E: Can not write log (Is /dev/pts mounted?) - posix_openpt (2: No such file or directory)
Setting up transmission-daemon (2.84-0.2) …
Failed to read /proc/cmdline. Ignoring: No such file or directory
[…] Starting bittorrent daemon: transmission-daemonstart-stop-daemon: nothing in /proc - not mounted?
invoke-rc.d: initscript transmission-daemon, action “start” failed.
dpkg: error processing package transmission-daemon (–configure):
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


And the solution was?

The point of this forum is to share problems and solutions.

1 Like

I followed the instruction by unuspromulti posted on May 31 and solved.

Thank you unuspromulti


Oddly I’ve just had the same problem after a firmware upgrade and had no idea how my instructions fixed it! I figure it had knocked off the mounts and had to do the below to get it remounted:

cd /mnt/arch # or where you are preparing the chroot dir

mount -t proc proc proc/
mount -t sysfs sys sys/
mount -o bind /dev dev/


Can you add aria2 to repo?

Good morning

First thank you for your work - I have used several packages from this repo and they definitely help make my clouds way more useful to me.

I would like to know if it’s possible to add truecrypt or it’s replacement veracrypt to the repository.

I have truecrypt working under Ubuntu quite nicely and it would be nice to add the same functionality to my myCloud.

hello, i want to install debian on my cloud ex2, i only can find debian for my cloud mirror 2

The information discussed in this topic is directed at the single bay first generation My Cloud units running the v4.x firmware. That firmware is DIFFERENT than the firmware used on the second generation single bay My Cloud and on the multi bay My Cloud models.

Trying to install Transmission Daemon, but get this message, anyone can redirect me? :slight_smile:

WDMyCloud:~# apt-get install transmission-daemon
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package transmission-daemon