Replacing a MyCloud disk (in Aug 2021 with Gen2 model)

(This is a re-post because I inadvertently posted it in the “MyCloud Home” section first :P)
(Although posted here, I believe it would work for the original MyCloud too.)

This is not a “detailed how to” but a summary of resources used and a commentary on some of the actions required.


  1. My backups started to fail to complete (I should have taken it as a warning!)

  2. Eventually I couldn’t login to MyCloud device on my PC (after entering the MyCloud IP address in my browser, either didn’t get the login screen, or if I did, was unresponsive). Reason for different situations depended on whether I did a reset (4 sec or 40 sec) beforehand.


  1. Getting inside the unit. There are multiple videos on the web that break the tabs and say it’s “not important”. Really? However, the best video I found used credit cards to disconnect the catches so that the cover can be slid off. It was from Erif Foorp and uses no words (How to open a WD My Cloud Case - YouTube). I used two cards so I could ensure I kept the first edge disconnected while I worked on the second edge.

  2. Initialising the new drive. I found a very useful video from 31Mike (How to Replace a WD My Cloud hard drive - YouTube) which described his experiences based on using (other) references on the WD Community forum.

  3. 31Mike used this reference from djh816 ([GUIDE] Debrick a completely dead MyCloud) as the basis of his work, with modifications that I suspect were related to the fact that he was replacing a 4TB drive with a 6TB drive (as I was doing, too).

  4. I used VirtualBox with the Linux OS used in SystemRescue ISO. The version I downloaded has been revised since 31Mike’s video so some of the references are different. I used “Boot SystemRescue using default options”.

7. Now comes the ‘difficult’ part

I am wary (from long experience) of instructions that use “magic numbers” without explanation, especially since my Unix experience is 20 years out of date. I had the “good fortune” however, to be able to look at the dead disk (only the user data partition is bad (at the moment) so I was able to verify that MyCloud indeed uses 7 partitions on the disk with the ‘second’ partition (sdX2) containing the backed up data. The partitions had the numbers mentioned in the 31Mike details.

8. The win

In order to look at the disk outside the MyCloud box I purchased a Simplecom docking station (Simplecom SD352 USB 3.0 to Dual SATA Aluminium Docking Station with 3-Port Hub and 1 Port 2.1A USB Charger) which, although being a little overkill, allowed me to clone all the good bits of the old drive so that I didn’t have to manually create the partitions, and neither did I have to install the image software.

GParted in the GUI interface recognised that the final 2TB of my new disk was “not defined”, fixed it so that it became “unallocated”, and therefore allowed me to extend the sdX2 partition to the full 6TB.

  1. I then reinstalled the drive into the MyCloud enclosure and after some minutes of flashing blue light, got the very welcome steady blue light.

  2. Logging on to the MyCloud drive and setting it up was straight-forward after that.

I hope this helps someone facing the same task!

FYI your previous thread is currently in the correct My Cloud (OS3) subforum but is locked. The My Cloud Home has it’s own separate subforum from the OS3 or OS5 My Cloud subforums.

The “magic numbers”…

mklabel gpt
mkpart primary 1049kB 2149MB
mkpart primary 8591MB -1MB
mkpart primary 7517MB 8591MB
mkpart primary 2149MB 3222MB
mkpart primary 3222MB 4296MB
mkpart primary 4296MB 6443MB
mkpart primary 6443MB 7517MB

Are the start/end point values for the 7 partitions used by the single bay/single drive My Cloud Gen 2 hard drive format structure. Generally one must use these exact values to properly unbrick the single bay/single drive second gen My Cloud drive.

Given my first mistake, I deleted the post from the OS3 subforum, because I was dealing with a Gen2/OS5 device (even though I strongly suspect this info applies to the OS3 device too).
I’m theorizing the end point of the second partition will change depending on the size of the disk you are dealing with. I recall 31Mike said something like it didn’t matter if you used the numbers from a smaller disk because “the system” would correct for the increased size of the new disk. I never tested that because when I used GParted, it detected the unused space and presented opportunities to recover it into the data partition… which I did.

Nice work!
Pasted to my WD Notes file. . . .

Depending on which directions used, the user partition end point was typically set to either “100%” (first gen #4 partition) or “-1mb” (second gen #2 partition) to expand the user data partition to the full size of the remaining hard drive capacity. Because of this the actual capacity of the drive could be almost any size and the user partition would be expanded to use that space/capacity. Generally what would sometimes happen is the Dashboard would (provided one used the correct exact values for the partition’s) report either the wrong capacity or 0K. One would typically do a System Restore through the Dashboard to fix this issue.

      • -although, TPH, if my vintage 2016 single disk my-cloud bit the dust; somehow I don’t think I would be putting a new hard drive into it. More likely build a new-NAS or if I wanted a project, I would look at something with a Raspberry Pi backbone.

Put an unused drive in it. It’s what I did. Put an old laptop drive that was sitting around unused into the enclosure. Keep it around as a backup to a Synology NAS. Unless going with an Raspberry Pi 4 you are not going to gain much read/write and network speed wise due to the limited nature of Raspberry Pi’s and their use of a single USB 2.0 lane that limits all shared traffic to around 300mbps.