Replacement of hard disk in WD My Book Duo 16TB: Unrecognized drive

Hi guys,

I just got my new hard disk for My Book Duo 16TB. Problem was that one drive crashed. The WD support sent out the right new one with serial number WD80EFZX-68UW8N0. Unfortunately, the device does not recognize the new second drive… I tried it several times. I also changed both drives and found the new drive still unrecognized in the device.

In any cases one LED turns red. And also the status within the WD Drive Utilities reveals that the drive is not installed (slot empty…).

Any idea?



Have you tried using the new drive on a desktop computer? Test the drive using the DLG tool by it self.

Problem is, that I cannot connect it to any other computer due to missing interfaces or cable connections.

Hi t-man,

You’re not on your own! I have the same problem with the 12tb model.
Correct replacement hdd supplied but not detected by Duo controller. I was able to format the drive in a USB enclosure and then mount it etc - but, still not detected in the Duo.
Luckily for me the whole kit-and-caboodle is eligible to return under warranty.

Hi Ken,

part of the problem is, that macOS’ disk formats have to be brought to the new replaced drives. I already got two new hard disks. Both have not been recognized. WD Drive Utilities went into a deadlock and in the end did not “find” the new drives and could not bring it online. As it has not been recognized I was not able to reformat it to HFS+. I tried it via Apple’s Disk Utility software on the one hand. Also via Terminal I had no chance. In the end the only way was to do it on a Windows computer as WD’s standard disk format is more compatible to this. Therewith the new drive has directly been identified so that Windows’s WD Drive Utilities software brings a “Rebuild” button to the surface… I never saw this button on the macOS version. I rebuilt the RAID on Windows, than reformatted and completely built it up from scratch basing an a macOS compatible disk format. Then I changed the device back to ma Mac. And now it works. I few minutes ago I again saw the same error message (?!). I really hope the the status is stable now! WD has no idea! The software seems to be buggy for macOS!!!

Hi t-man,

Must admit to having an urge to stick the system onto a Win machine, then thought that I’ll just stick it! By returning it on warranty, i’ll be in a win-win situation anyway…

I did, by the way, reformat both drives with HFS+ in the disc caddy on the iMac. I also moved their position and only the original disk was recognised.

As to the WD software, the less said the better. Just horrendous.

In fairness to WD they do indicate, by the lack of content, in their manual that macOS is a secondary system.

Good luck with yours!

Hard disks exchanged by WD - also complete drive exchanged. Problem occurs again. Root cause shows that main problem is not the hardware, but the macOS software WD Drive Utilities. In fact, the software reacts different on Windows computers and macOS computers. I again became the error message on my Mac. So I tried it on a Windows machine. This machine showed a function to restore the RAID functionality - the Mac does not in the same situation?!! WD support does not now this behavior and does not help. WHAT NOW??

1 Like


Sorry, I should have re-visited this topic with my end result.

I eventually decided to return the whole unit, no questions were asked and no difficulties were tried by WD to stop this occurring. Have to give them credit for this.

Frustrated, I did connect this to a Windows laptop. Hey presto! everything worked - instantly.

Re-connected to the iMac and have used it transparently ever since.

Perhaps, one day, WD will update their software. Until then I would suggest not buying these units as they are not currently fit for purpose.

Hi all,

this thread is quite old but maybe there is still someone who is able to respond. I tried to exchange the drives from my My Book Duo (first generation) with two (used) drives of the same kind. The drives have been used before and were formatted so that they can also be used directly by plugging them into a SATA port of a PC (Win10). I wanted to load the Book Duo with these drives and re-configure (+format) the drives to build a new RAID1 array. It was not possible to format those drives via the WD Drive Utilities software … so no configuration of the RAID possible. The drives seem to work fine (SMART status is good and they both work with my PC directly). Something seems to be wrong with the Book Duo. Maybe it only accepts completely ne drives. Any suggestions?!