Repeatedly asks me to download Java 7 Update 45

When I go to wd2go and click on my cloud drive, I am prompted to download Java 7 Update 45.   I do the Java install successfully, and use the Java verify tool to verify that version and update is installed, an even reboot my computer, go to wd2go and my cloud drive, and I am again prompted to download Java 7 Update 45.  I don’t have any other Java version installed, and I can’t get past this.  This happens on both my Windows 7 Pro 64 Bit Internet Explorer 11 and on my Mac laptop with Safari.

However, if I use FireFox on my Windows 7, then go to wd2go and my cloud drive, I get a warning that “The certificate used to identify this application has expired”.  If I click to accept the risk and start the application, everything works fine and I can see and work with my WD shared folders.

On IE 11, if tried adding "" to trusted sites, and turned off all certifcate checking, but still prompted to download Java 7 Update 45.

My guess is that perhaps Java / JavaScript is DISABLED in your browser settings?

Check here:

I have “scripting of java applets” enabled in Internet Explorer 11 and almost every other option enabled to try to solve this problem.  I also added and the longer as Trusted Sites in IE 11.  Other java applications work fine in my IE 11.  It appears that attempts to check my java version and does not recognize or detect it properly when using IE 11.  I installed Chrome, and it works without any problem, just like FireFox.  I tried from two other computers, one with IE 8 and one with IE 10, and they both work fine.  I tried from a different computer that has IE 11, and same problem.  Seems to be an compatibility problem with Internet Explorer 11 (32 bit)  with Windows 7 Pro (64 bit). 

IE11 issue.  Try with Chrome or FireFox