Renaming WD MY BOOK ESSENTIAL Drive


#1

Hello:  I have two  2TB WD “MY BOOK ESSENTIAL” drives that I am trying to connect to a IOMEGA IConnect  Wireless Data Station.  The problem I’m Having is that the IConnect will only see one or the other drive due to the fact that they both have the same name - that is “USB_WESTERN_DIGITAL_MY_B_1”.  I tried to rename on of them by disabling the smartware software and deleting and creating a partition with a new volume name but this did not work.  Is the name of the drive in the firmware? and can it be changed somehow?  Thanks


#2

Hello,

What Operating System are you using?

Are both WD drives been recognize by your computer at the same time?


#3

WD Ex-HDD name is on firmware (Device ID)

Why don’t you contact Iomega support… they may have a workaround!

https://iomega-na-en.custhelp.com/app/cust_alp/p/1031,1074


#4

Had a similar problem with Iomega Iconnect and two WD Mybook drives - One a 1.5T Essential and the other a 320Gb Essential. The Iomega iconnect would name them the same “USB_WESTERN_DIGITAL_MY_B_1” and then gets confused in the customised setup (where you can set your own drive share name) - often randomly swapping  names or sizes?? Each drive operated fine (but slow) when connected without the other in the Iconnect and are 10x faster in the PC (where both pickup very different names).  Tried to resolve with Iomega but with little success - was offered a return to base - but opted to disconnect one drive and plug it it the USB NAS drive of Router. Don’t think it is a Smartware issue - I never enabled it from the start. Probably where the Iomega takes the name from the WD firmware (although I couldn’t find it in device properties?) - I suspect a bug that maybe corrected in a update by Iomega. Odd more people haven’t had such a problem using two WD drives?