Remove Write Protection on WD 1TB external hard drive on my MacBook Pro

I am trying to back up some iTunes files into my WD external hard disk, but i am unable to due to write protection. How can I remove this?



Hi Lolo70:

Have you set a password to your external drive?

Have you format your drive for MAC?

Note: Click the Kudos star to say thank you for helpful posts. And click the ‘Accept as Solution’ button for the post that solved your issue.  

1 Like

i haven’t set a pwd. nor have i formatted. i don’t think this is the issue though. once i ran software on another computer running windows xp, i can write to this WD HD with no problem. i have another pc which runs windows 7 and it is having same issue as my mac. i just do not want to run any software on my mac in order to be able to write to this WD HD. this can’t be this hard, but aparently i am not the only one that is having issues…

If this drive is formatted for NTFS Windows it will be read only on the Mac. Try NTFS-3G and see if that takes care of the problem.