Remove Public Share

I can’t upgrade to OS 5 so can only connect locally to my MyCloud Os3. WD support is no longer there, so I now wonder why I can’t do what I want with my MyCloud. I want to remove the Public Share, but I can’t, it keeps coming back, it’s baked into OS3. Because remote access has ended and I no longer need that public share, I want to get rid of that share, does anyone know how I can get rid of those share(s) permanently?

Do a subforum search, magnifying glass icon top right, if you haven’t done so already. Its a well discussed issue with several possible methods of removing or hiding the “Public Share” on OS3. All methods will involve enabling SSH in the My Cloud Dashboard, connecting to the My Cloud using SSH and editing some files at the root level.

For example this discussion:

Warning: As always you proceed at your own risk when using SSH and modifying the OS3 firmware!!! One can easily render their My Cloud unusable by issuing the wrong Linux command while using SSH.

1 Like

I had searched but because my english is not that good, I didn’t find the right posts.
I’ve looked at your tip but I think SSH is a dangerous area, I’ve worked with it before but I’m an amateur.
I’ll dig into it and maybe try it out.

Another example discussion of removing the Public Share:

And from that discussion is the following link:

If you are using a single bay/single drive My Cloud then you will need to check the version, which is denoted by the firmware or by the P/N number on the bottom of the unit. The directions may be different for each version; first gen or second gen.

First Gen: V3.x/V4.x firmware P/N # ends with “-00”
Second Gen: v2.x firmware P/N # ends with “-10”

1 Like

Help required I can no longer access my cloud os 3 with either iPad or laptop how can retrieve all photos and videos this very galling

Did you remove your Public Share? If not then what does your question have to do with this subject discussion about removing the My Cloud Public Share?

If you are having a problem accessing your local network My Cloud start a new discussion and detail the problem including what color the front LED is, what troubleshooting steps you have tried, what firmware version (if known) your My Cloud device is running, what operating system your using. Otherwise all one can do is guess as to what your problem is.

I followed your tips and this is how things stand now.

I have tried several options.

The most important thing is that you make backups before you start making changes so that you can recover everything in case of errors.

The public folder is no longer visible in Finder.

Still in the server dashboard, it cannot be adjusted, the share remains visible there and access still cannot be adjusted.

The most important thing for me is that via finder the share is no longer shown and is therefore not used.