Remote Backup - Destination My Cloud using dynamic IP

Hello,

I am looking to purchase 2 x My Cloud EX2 and to use each one in a different geographical location. One location (A) has a fixed IP address, the other location (B) does not and the ISP for B does not offer fixed IP addresses as an option (and I’m in an 18-month contract with them!).

I have read (several times) this KB Article (11807) that states “My Cloud(s) must be configured with a static IP addresses”. In my scenario, that is not possible and I need to remote backup from location A to location B.

In location B I can configure my router (and, I think the My Cloud: Dashboard -> Settings -> Network -> Dynamic DNS) to use a dynamic DNS service such as DynDNS. However, Step A-4 and Step C-1 in the referenced KB Article both refer to entering an IP address into the Remote IP Address field in the Backups -> Remote Backups -> Create Job -> Remote Backup Settings window on the source My Cloud device in location A.

Does anyone know if I can enter a domain name in this field? If I can, will the source My Cloud resolve it correctly via DNS and will the remote backup still work?

If this field will only accept an IP address, can I manually edit the appropriate config file via SSH and replace the (dummy) IP address entered with a domain name? Again, if I can, will the source My Cloud resolve it correctly via DNS and will the remote backup still work?

Any help and advice on this would be very much appreciated.

Thanks & Regards, SteveB (UK)

Hello Steve,

Unfortunately, You will need to assign static IP address on both of the My Cloud devices for Remote backup as DynDNS is a third party domain and we have not tested our My Cloud drives with it.

Hello,

Thank you for your reply but it does not answer the very specific questions that I asked.

The fact that DynDNS (or similar) is a third party domain is, in my view, not the point. I need to know whether a domain name can be entered into the Remote IP Address field in the Remote Backup Settings window. If that field will only accept an IP address, can I enter a dummy address and then modify the appropriate config file afterwards, replacing the dummy IP address with a domain name? Will a config file with a domain name in that field load correctly? If it will, will the system software correctly lookup the IP address of the destination backup server using the supplied domain name via DNS?

Personally, I think these questions can only be answered by (a) consulting the source code, or (b) by trying it out on a My Cloud EX2 Ultra running the latest firmwear (unless another community member has already tried this out and can share their experience!).

I look forward to reading a more comprehensive reply, given the sale of two units depends on the answer given.

Regards, SteveB (UK)

Hello again,

Does anyone in the community know if this can be done? Have anyone tried configuring a My Cloud EX2 Ultra running the latest firmwear in this way? Any guidance most welcome!

Thanks everyone.

SteveB (UK)

Hi,

I’m also interested in answer for the question above - does someone knows the answer?

If I, for example, buy https://www.wdc.com/products/personal-cloud-storage/my-cloud.html#WDBCTL0030HWT-NESN
can I set it up using DynDNS, no-ip or some similar third party service?

Thanks,

Synology devices support dynamic IPs so I guess that’s better choice, even though they are more expensive … Better than risk it and throw money for nothing.

Hi Steve,

Did you ever receive an answer/solution from WD on the above problem or did it transpire that the dynamic WAN IP was not a problem?

If you could cast any light on this it would be much appreciated.

Thanks

Rob

Hi Rob,

I went ahead with my purchase and investigated this further myself as I couldn’t get a definitive answer from WD Support.

There are two key points to consider:

  1. The mechanism for enabling/managing a dynamic IP address
  2. The ability to reference the remote MyCloud by domain name rather than IP address

Re (1):
The MyCloud firmware (v2.30.181) on my two devices does support dynamic DNS services (under Settings -> Network -> Network Services) but I didn’t actually need to use that feature. Most modern broadband routers also support dynamic DNS services and I felt it was better practice to use the router to manage this (at point of connection) rather than a device behind it on the local network. I therefore set-up dynamic DNS using the free changeIP service and that has been working fine. Consequently I never had the need to test the WD feature. If it’s critical for you to know that it works, I can test it for you - just let me know. Note, however, that the MyClould dynamic DNS feature only appears to support www.DynDNS.org and no-ip.ddns out of the box, so you may have more choice using the router in any case.

Re (2):
Where the remote MyCloud device (backup target) is connected to the Internet via a dynamic IP address, you need to configure the remote backup job on the backup source to use the previously established dynamic DNS name. I can confirm that a domain name can be entered and is accepted by the MyCloud GUI in the “Remote IP Address” field when defining a Remote Backup Job, despite the info icon stating that you have to enter an IP address.

I have tested/implemented the above and it is working for me. I hope it works for you too!

Kind Regards,

SteveB (UK)

@SteveB99

Hi Steve,

Would love some additional information on the solution you configured. I am attempting to perform a backup to a remote WD server at an IP address that has remained static despite many attempts to have the ISP renew my IP address as something - anything - other than the IP address currently assigned. The IP address currently assigned to the remote destination WD PR4100 is xxx.xxx.xxx.255. And in my attempts to create the remote backup, the source WD EX2 will not accept the external IP address for the destination PR4100 because that ISP assigned external IP address ends in .255. I went back and forth with WD support and they said they don’t support IP addresses ending in .255 because of smurfing. They ended the support then and there and said I had to contact my ISP to be assigned a new external IP address for destination and thus for the destination PR4100.
I would love to be able to use the Dyn DNS service I have paid for to solve this problem and it reads as if you were able to accomplish this somehow. To be honest, I don’t know if I have used all the appropriate or correct terminology but if you can understand the gist of my issue I would be grateful for any guidance you might be able to provide. To date I have experienced nothing but frustration trying to communicate with the professional customer support at both WD and my ISP despite my best efforts.
If I could just enter into the destination remote IP address (while configuring the remote backup from the source WD EX2) something like “www.smartishhomedoesntknowwhathestalkingabout.net” and have Dyn DNS resolve that to the correct IP address at the destination server location that would seem to go miles toward fixing the issue I’ve been experiencing for months - which has made it impossible to perform a remote backup to a different geolocation. I’m basically at my wits end.
So thanks in advance for any assistance (and happy to provide clarification should that likely be required).
Best regard,
Adam

Hi Adam,

An interesting “restriction” by the WD designers/engineers! Using a domain name instead of the IP address ending .255 SHOULD work providing WD have only engineered the restriction in the UI - if they look at the IP address AFTER it has been resolved and BEFORE the connection is made then you’ll be out of luck I think. Certainly worth a try though.

My two MyClouds are now running firmware v2.31.183. Unfortunately, this version still appears to restrict you to using either the www.DynDNS.org or the no-ip.DDNS service. However, as I stated in my Apr’18 post, I did not use the MyCloud DDNS feature, preferring instead to use the DDNS feature of my broadband routers as the routers are the default DNS Servers for my LANs.

Once you are confident that your DDNS names are being maintained and resolved correctly, you simply need to enter the appropriate DDNS name (e.g. smartishhome1.dyndns.org) into the “Remote IP Address” field of the MyCloud GUI when defining a Remote Backup Job. Also remember that prior to this you must successfully complete the steps outlined by WD, namely:

  • The remote Server setting must be turned ON in the remote MyCloud system

  • The backup password for the remote MyCloud system is enabled

  • You have added port forwarding rules for both SSH and Remote Backup services in Settings > Network > Port Forwarding in order to see your MyCloud system over the internet (I think this action sets the required rules in your router - if not, you will need to set them manually)

Hope this is of some help.

Best Wishes, SteveB (UK)