Remote Backup and SSH checks failing

I purchased two UltraEX2’s and set them up on a private LAN. After configuration, I moved one of the two to another private LAN and reconfigured the IP. I can see and manage both devices from the MyCloud app just fine.

I want to create a remote backup job on both devices that will copy over a specific share of data to the other, in effect it will provide offsite storage of surveillance video to each location.

In private network “A”, everything is set up and working fine, in regards to the remote backup being set up and the Remote Backup and SSH checks “passing” the port forwarding. In private network “B”, the port forwarding checks are failing, thereby causing the mycloud remote backups to fail.

I set both myclouds up exactly the same way, that didn’t work for site “B”. I tried changing the port numbers for site “B” but that didn’t work, went back to standard.

Both sites are using Comcast Business Internet. Site “A” has a TPLink cable modem/gateway. Site “B” is using the Comcast cable modem/gateway. The TPlink at site “A” has no firewall rules set up. The Comcast Gateway at site “B” does have firewall rules…I set up port forwading on it to allow 873 and 22 but the port forwarding checks on the site “B” mycloud is still failing. I tried using the DMZ host feature on the Comcast gateway to put the mycloud ex2 at site “B” into a DMZ to allow the mycloud to have no firewall rules in place and it still fails the port forwarding checks.

Like I said, I can get to both devices just fine with the mycloud app on my phone or computer, I just can’t get site “B” to pass the port forwarding checks.

Should I be focusing on the Comcast cable Gateway at site “B” or focusing on the MyCloud at site “B” for troubleshooting?


You should post your question (or search) to the dedicated EX2 subforum where people more knowledgeable about that unit may be able to assist. This subforum (My Cloud) is generally for the single bay/single hard drive My Cloud units.

Can I move this one or do I need to repost?


I already moved it.