Remote Access?

The WD workaround for the Heartbleed Bud Issue is as below, and that is fine because I understand that this is not a WD problem;

Highly publicized recently…… While single-user storage devices are unlikely targets versus large Web services reported to have intrusions, click here for instructions on how to disable remote access as a temporary workaround to address this issue. Please contact WD Support if you need help or have questions.

I performed, as suggested by WD, the above workaround and disabled remote access to my MyCloud. The Mycloud dashboard informs me “cloud access is disabled” okay that is what I wanted.

Not having looked at the dashboard for a few days, thinking I’m okay , I needed (as I normally do several times per day) the Mycloud on my LAN to get me access to my files. Thinking let’s have a look at the remote access setting and sure thing the MyCloud is connected with relay connection and not port forwarding as it should be.

I have to reset my router to get port forwarding again is this WD intervention on customers LAN / hardware level?

What can I do to start believing in this product, the remote access workaround worked for a undefined period of time. So exit workaround? been open for attacks for how long although I’m “a unlikely target” according to WD, see above. In a way correct I am a very small player, call it just a customer , in the world of NAS and WAN, LAN however does that matter?

Questions now are:

Why does the Mycloud connects itself again without letting me know because I have enabled the option for a notification email to be sent for all events on my MyCloud, is this normal?

What is the solution for this? Can I without hacking into the firmware solve this today without pulling the cable out of my router.

When will  the new firmware be released where this is solved?

Are the developers working as hard as I hope they do?

What is WD’s marked strategy for this product?

Currently the sales department is doing a better job than the product (development) department. Is there any competition amongst you guys? Would be good for the customers, I can tell you that for sure.

I am not following. If you disable remote access, you have disabled it and the dashboard doesn’t show either relay or port forwarding status, it just shows, well, “Cloud access is disabled”.


Are you saying that you turned it off , and that the toggle button came back to the “on” position without your intervention?

Hi Etupes,

I am sorry that the message was mixed-up.

Yes the toggel button was shifted to ON again without my intervention.


Is this normal?

Well no, this is not normal :slight_smile: I am wondering if other users have seen this. I am less worried about this after I have applied the manual fix, but stil…

Etupes wrote:

Well no, this is not normal :slight_smile: I am wondering if other users have seen this. I am less worried about this after I have applied the manual fix, but stil…

The real issue is the fact that if you apply the manual fix and something goes wrong then your warranty could be void according to WD’s warranty. This is really no choice at all … void your warranty or take your Cloud off-line and lose internet access, which is one of the reasons for purchasing. I am seriously losing faith in WD’s capabilities.