Remote Access Problems since changing iPhone 6 to a iPhone 7 Plus

I have had a MyCloud 4TB drive since they first came out. It worked beautifully up until November 2016 at which time I changed my iPhone 6 to an iPhone 7 Plus. There was also a Apple OS system upgrade in this same time frame. If either of those 2 things have any bearing on my problem. Since then I have had nothing but trouble connecting remotely from my iPhone. It is hit and miss. From my Win7 PC, which is hardwired to the router my drive is hard connected to, it always great, all the time.

I can mess around and eventually get it back working but it seems to only work for a short time, like a week or so. Restoring seems to be difficult and I can do the same steps exactly the same way and things will still not work at times.

So here I am again today trying to remotely save a photo from my phone to my MyCloud drive. I have tried both going cell signal through Verizon (with Wifi OFF), and also attempting to save going with Wifi ON.

Here is my sequence that is again failing. Everything worked yesterday. I open a photo on my iphone I want to save. Click the send icon. The selected photo is check marked. I Select the MyCloud app icon that appears in a list of apps available. I get a message “No Device Added” Please add a drive and retry uploading your files. My only option is to then select “OK”. Then I am back to the checked marked photo on my iPhone.

If I log into my MyCloud drive through my PC and open the (dashboard >Cloud Access) the section at the bottom "Cloud Devices for my user name, indicates in one of the rows “my iPhone” “WD My Cloud” “Connected”

In the past I have deleted the app on the phone, reloaded it. Deleted my phone on My Cloud dashboard as a device under my User, sent myself a new code and started over. This doesn’t always work either and seems like the long way around a mountain for nothing. Tired of you know what’ing with this. Getting ready to go buy another brand of drive.

Can anyone help before I throw up my hands and give up?

It all sounds good to me, and the only thing that changed is the phone, so maybe it IS the phone causing the issue. How is phone in all other respects; even with the other MC app features? Have you tried completely rebooting the phone both its ways?

Yes…have tried rebooting phones (Didn’t mention my wife switched her phone at the same time and hers has the problem too.

She just gave up and no longer tried to save that way).

I have to assume there is some issue with the iPhone 7, Apples latest OS upgrade, or some setting that has changed that I have no clue on how to fix.

Have tried rebooting the MyCloud drive. Have rebooted my whole system including router. I have 4 WD drives of various sorts on my system. Only one is a MyCloud Type.

What is the simplest way (the Steps) to reconnect? I am about to give up on this drive if I can’t resolve this. Doesn’t WD have call in support techs that can walk me through this? Otherwise I am going to have to go back to using my Seagate drive. If stuff isn’t isn’t plug and play without problems I not tech savy enough to resolve this. I don;t have time to keep dealing with this. I am sure I can struggle through this and get it to work again, but it will only quit again.

Please Help


Please try this step

  • open the mobile app
  • delete the My Cloud device
  • reboot the phone
  • connect to WiFI
  • download the My Cloud Mobile App
  • turn OFF wifi and force the use of your carrier network
  • open the My Cloud App
  • login using your My account and wait for the My Cloud device to be added automatically
  • upload a file test
  • close the app
  • turn on Wifi
  • open the app
  • upload a file test


Try above steps first, or perhaps after you have compared phone settings of old phone versus new phone settings. You might get some insight to problem this way.

If still no success, reply back here to SBrown’s post. WD does have a call in support line, but calling in might get you to first level support, and you need second level or better if SBrown’s tips don’t solve problem. Hopefully, he can continue to assist you here, but if not, see this link:

You can Reset Network Settings & Reboot, Check iPhone for Available Cellular Carrier Updates, Update iPhone System Software to the Latest Version and Contact Your Cellular Provider

Thanks for the info i am also having same problem when i going to change the iPhone 6 to iPhone 7. After changing this i have an issue of my iTunes account that is iTunes error 4013 so if any one have suggestion then please suggest me.

If it is the iPhone issue, you can try rrestarting or hard rebooting your device. Also, try to reset network settings from iPhone settings or update your device. If these do not work, you can use an ios repair tool like TunesKit to fix the issue.