Remote Access issues

When i try to access my wd storage device remotely to play a film it will log on, show me my list of films, start loading it up but then will only play 2 secs, pauses for a bit and plays another two seconds. The internet signal is great. It happens on my laptop and on my phone. Works fine at home but not remotely

Any ideas? Is it because the files are .mkv?

So you are downloading your movie over the internet to display on your phone?

There are number of issues here, probably not related to mycloud but more like internet network related.

 What type of router are you using for uploading this data to the internet. ADSL, VDSL, Fibre?

ADSL offers a fairly poor upload speed of ~100 Kilobytes per second. This may not be enough bandwidth to travel from your local mycloud network into the internet and onto your phone for your movie.

VDSL offers around 1Megabyte per second and will likely play most movies in standard definition. 

Fibre is independant of the copper phone limits and offers the best solution. Bandwidth is limited by the ISP.

So thats your upload speed from the internet  to take into account… Now your phone network.

So now let say you have ADSL for upload, and your phone is on, let say 3G which which offers say 1MB per second download, this also may not be enough bandwidth.

Also, consider the distance from your phone and your network, and how many network connections your data must travel before it reaches your phone. This is called latency, or the amount of time your click a button and  its transmitted to your mycloud on your home/local network and then sends a response again. This speed can be quite variable especially when your over differing states, citys, countries, network ISP’s. Basically, you speed of your network is determined by its slowest link… and that link can be anywhere from source (mycloud) to destination (phone).

So, once you accounted for all these variables in rermote network speed, you can calculate your actual bandwidth independant of your mycloud server… and this is probably why your phone is buffering your mkv movie,

its likely it doesn’t have enough bandwidth to continuly download the movie data and play it at the same time.

I’m sure your experienced the same issue with other online movie sources like youtube.

Hi, youtube, bbc videos, itv player, iplayer, netflix and lovefilm all working completely fine…just not able to remotely view films from wd storage device. Generally around here (where i have tried watching things remotely from a variety of homes) we get 6mps download, 1mbps upload and ping of 60 according to OOKLA Speedtest, but even when i was in Birmingham at a friends home where he gets 47mbps download, mbps upload and ping of 15 i still had the same problem

The last figure was meant to say 3mbps upload

Try this, instead of viewing your movie, try downloading it first to the local disk, then view the movie.

The download speed will give you your actual delivery speed from your remote mycloud through your router -> internet -> local router/phone.

Don’t be fooled into thinking speedtest sites reporting correct speed, its only testing your isp and not your remote mycloud network connection.

Hi,

If i connected to the internet at a friends home via my smart phone and i want to remotely watch something off my wd device at home, i cant do any ‘downloading to the local disk’.

Also, surely one of the dozen locations in a variety of places i have tried remote access would have been suitable for the connection.

Thanks for the help so far