Remote access disabled 970 error on Android phone when on 4G

This is really starting to bug me now. I have my 4TB My Cloud set up and light is steady blue. I have set up my Samsung Android phone as a user and I can access my files via wifi when I am at home and logged in to my domestic network, so the sharing is set up correctly.
However, when I am out & about and my phone is connected via 4G I am unable to access my stuff, I get the “Remote Access Disabled (970)” error.
So when I got home, the phone automatically connected to my domestic network via wifi and voila, there are my files. So, I straight away I switched off the wifi on my phone, checked that I had 4G coverage and tried to access the files and got the Remote Access Disabled (970) again.
So am I missing something here? Can I only access my stuff on my own network? I can’t see the point of the My Cloud if that is the situation.

I’d recommend confirming if you are able to access your My Cloud from your phone while using a different WiFi Network. If it works then your phone carrier could be blocking remote access services.

If it does not work I’d recommend double-checking your unit’s remote access settings since local access can still be granted in an improper configuration.

Same problem with my network/phone. Have you fixed it?

I also have same problem, it can be solve when you delete your account in cloud access and create new account . there is no problem if you still using previous email .

I have deleted my account and still not working

Hi, I have the same problem too, did you manage to find a solution?