Remote Access Connection Problem


I get this frustrating message whenever i enable remote access.

“Cannot establish remote access connection. Make sure you are  connected to the Internet. (Error 31520)”

I came across other users posts and found that its a global issue, not only me.

Why do i need to spend money on a cloud storage device if i use it only as normal external storage? … I purchased this unit especially to turn on my own cloud storage so i can access it from anywhere in the world. Now, its functioning as local external storage device.

Firmware is updated to the latest version:02.43.10-048


something is probably wrong with the router firewall.   There are a lot of moving parts in these types of set-ups, and most of them have nothing to do with WD.

Firewall is configured for port forwarding just fine. There are many other applications that use port forwarding and all are working. I did the same configuration for the WD unit with no luck. I see traffic hit the WD PF. I am sure its a problem with the WD 2go server.

Then rebuild the wd2go server.  The option is in the dashboard. did you check that the right ports are open?  That wd2go on the MBLD could connect to the WD server?  That’s all in the dashboard.

Also, install Accessbook from for a much better remote access system. and try ownCloud for another method. and also OpenVPN. 

Sorry for not clarifying this from the beginning, i am an IT guy. So, i checked everything you said. The right ports are configured for port forwarding correctly (80 and 443). Rebuilt the wd2go database. Created an outbound firewall rule specifically for the unit and i don’t have proxy. I see traffic hits coming in the outbound rule, this means that the unit reaches the internet successfully.

Is your outbound firewall blocking ANYTHING from the Duo?   That message typically indicates it’s not able to pass the Connectivity Test.

Look at your DENY logs and see if there’s anything from the Duo outbound that’s getting blocked.

Also, read this:

That’s with respect to the My Cloud NAS, not the Duo.

I’m not sure how the Duo does the same test…

Tony is correct.  You have probably set the MBLD to Static configuration, but didn’t set a proper DNS and gateway.  Change the MBLD back to DHCP, and then use the router config to set a static IP for teh MBLD.   In other words, the MBLD is better with a Static IP, but the setting should be at the router end and not at the MBLD end.

Since you are an IT guy, did you do a ping test from the MBLD to the internet to confirm that the MBLD actually has an internet connection?  If you can get a ping, then the wd2go should work since it also is an outbound signal from teh MBLD to WD’s servers to tell them what the ISP IP address of your MBLD is.

Do you have any other hacks installed ? 

Thank you guys. Its working now.

The firewall CPU was high and i had to restart it. Its a company firewall not home.

Hi, I have the same exact problem. How ever I have no IT knowledge at all. Can you help me somehow?