Registers on computer but not TV or Media player...Why?

Recently bought a Passport Ultra, formatted to fat32 and placed movie files on it all worked on my computer. I then plugged into my WD media player and it won’t recognise it, it asks for the password which i entered then it constantly says no storage present. My passport ultra that i bought a year ago is recognised by my media player i thought it was because the firmware was not updated on the WD player but i did that and it still does not recognise that there is any storage. Has someone had a similar problem is it something that i can fix or is it a warranty issue? Thanks


If you connect the drive to the computer, and remove the password protection, to test of course, and then connect it to the media player to see if it comes up. Another question just to clarify, the drive is formatted in FAT 32 not EX FAT?

It doesn’t give me the option to format it to fat32 only Exfat and a few others. I took the password off and it still doesn’t work. I can try to erase the disk again and reformat it but I don’t know why it’s not giving me the option for fat32. I have a Mac Yosemite 10.10.5