Refuses to connect to the internet

I have followed the instructions to the letter on this %$#&ing thing and it does not work.

Tried both the reserved IP address based on a mac id in the DHCP and I have tried Static with the ipv4 and dns as per the instructions. The my cloud has managed for a whole two days to work properly, but has since given nothing but CLOUD ACCESS STATUS CONNECTION FAILED

I have toggled the remote access and triple checked the static ip. I have spent days fighting with this ■■■■ thing and it is more frustrating than trying to get a politician to tell the truth.

Hi @SRW - Do you have access to another network by chance? I’d like to see how it behaves when connected to a different router - my gut feeling is that this is a network issue but the quickest way to tell for sure is to simply plug it in somewhere else if that option is available to you.

  No. Just the one. I have a cable modem. Arris SURFboard SBG6580 that is a cable modem feed. 

Not sure if it matters but, I have the firewall enabled for medium.
Ports configured the forwarding and the ports 80 and 443. Since 443 is
standard HTTPs it shouldn’t matter, but I have forwarding set up to the
reserved IP and the internal Start and End for 80 and external for Start
and End for 443.