Red light on gen 1 My cloud

Currently have a 3Tb gen 1 My cloud firmware 04.05.000 342 with one 8Tb + 3Tb drives attached to it via a USB hub.

Running windows 10 / android for the app

It currently has a Red light.
When I tried to access it from the app tells me it has trouble connecting. make sure device is powered up and connected to internet.

Tried connecting to my laptop with a different new ethernet. No change

If the issue with my current my cloud is a hard drive issue could I get a new my cloud and attached the 8+3 to it could I retrieve my data or would it overwrite the drives?

If it’s a ethernet port issue could I put the cloud drive on a USB hub with the other two drives and access the data?
Lost my backup drive about a month ago so hoping I can get this data back

Thank you

Hello,

Please refer to the following KBA article: https://support-en.wd.com/app/answers/detail/a_id/24755/

Thank you for the update but I am not able to access my dashboard.

The unit currently has two external drives attached to the cloud unit.

Could one buy a new unit and connect the two external drives and not lose the data on those drives?

I have directly connected my cloud to my computer per procedure.
Red light still comes on after a few minutes
I am not able to access my dashboard

I did buy a new unit. I am having trouble accessing my data on my external drives
The new app reconizes them but not seeing the data.
It’s probably because they weren’t properly ejected due to not being able to access dashboard
At a total loss on how to proceed