Red light error [SOLVED]

Hi all,

First of all sorry for my poor english.

I hava a 3TB WD My Cloud. Yesterday morning the electric company turned off the light for maintenance and turn the light back, the hard drive showed the red LED.

DataVolume can not be mounted by it self. I have to loggin using ssh. When I execute /etc/init.d/ i can see my data but I can not access through samba.

Parted shows this info:

Model: ATA WDC WD30EFRX-68E (scsi)
Disk /dev/sda: 3001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
3 15.7MB 528MB 513MB linux-swap(v1) primary
1 528MB 2576MB 2048MB ext3 primary raid
2 2576MB 4624MB 2048MB ext3 primary raid
5 4624MB 4724MB 99.6MB primary
6 4724MB 4824MB 101MB primary
7 4824MB 4826MB 1049kB primary
8 4826MB 4828MB 2097kB primary
4 4828MB 3001GB 2996GB ext4 primary

Seems to be no problems with superblock on / dev/sda4

e2fsck /dev/sda4 seems to be ok.

I reset using the 4 and 40 seconds. I upgraded to the latest version from ssh and after starting the light finally turned blue, but before sharing folders and restarting the hard drive, the LED returned to light red.

I have not even tried a factory reset because I have no space to make a backup to another hard disk.

Can anyone help me?

Thank you

You better stop fiddling around before the box no longer allows SSH.

I recommend to avoid rebooting because this is a very instable situation now.

The fastest and safest solution is connecting a USB drive and copy via SSH all from sda4 to that drive.

Only after that you can try to get it fully working again.

I have already solved by ssh upgrading to the latest version and performing a system reset.
The problem was in the installation of Webmin. I think something was changed by Webmin.

These are the steps I followed:

1 - Download the firmware from
2 - Mount DataVolume  # / etc / init.d /
3 - Copy the unzipped firmware / CacheVolume and rename update.deb
4 - # / CacheVolume / update.deb
5 - # reboot
6 - Logging UI using user admin
7 - Applying system restore

Now everything works fine.


Very courageous. I have seen too many bricked Clouds to dare that route.

“Dem Mutigen gehört die Welt” is a famous german proverb :open_mouth: