Red light and cannot install

Everything was fine for quite a while. Then I took the device out of service for a couple months. During that time, upgraded primary pc to Win 10, also still have Win 7 machine Tried to put MyBook back into service --** get steady red light in front**. Don’t have software on computer, so went to download it. It won’t install on either machine. Software from http://setup.wd2go.com/?mod=product&device=mbl Install fails immediately – even before clicking agreement. Says “Setup has stopped working- a problem caused the program to stop working correctly” I get the same result on both machines. I have Norton Security. Really could use help for any solution - either to get this installed and back in service, or just to get my valuable content off the drive. Thanks!

You do not need software in order to use the unit. If your WD My Book Live displays a red light then it’s a sign of a connectivity issue or a hard drive failure. Try replacing the Ethernet cable and connect the unit to a different port of your router. If the unit still has a red light then it should be replaced under warranty.

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty

If data recover is a concern then I would recommend contacting a specialized data recover service company.