Red front light since yesterday (5/24/16) New firmware?

What reboot did you do? A 4sec reset, or a 40sec reset?

After shutting down your My Cloud how long have you waited before trying to restart it? I suggest this as a start, giving it time to cool down before restarting, to see what happens.

The following link is about SMART failure. Hope it helps.

I tried both. No effect.

I have waited for about 30 minutes. Does it matter? I don’t think it was overheated or something.

all too common. if you are ever able to get it back, turn off auto-updates. I am at ver
2.11.133 and will probably stay there until I replace this unstable disk holder.

What is “all too common”?

Generally when one gets a red LED it means either the drive has failed, or there has been some corruption of the folder/firmware that is preventing the My Cloud firmware from booting.

Could it be firmware related? Possibly but if it was “all too common” then there would be numerous posts immediately after the firmware was released. That hasn’t been the case based on posts here.

The OP hasn’t responded yet (apparently) if they have SSH access. Or if they do have they tried to access the My Cloud to see the folder structure and or manually trigger a firmware update. One method of manually updating the firmware via SSH is explained in the following post:

https://community.wd.com/t/wd-my-cloud-v4-x-and-v2-x-firmware-versions-download-links/148533/7

While most won’t have a problem with the automatic firmware updating, some may.

I was contacted by WD support, they suggested a “system only” reboot through the dashboard site. It says that all the data remains intact, so I did it.
The front light on the device became blue for now, but it seems that I need to configure the whole thing again. On the getting started card --> sign up for my cloud account, I put my name, surname and e-mail address and have the following error: “Failed to update user (400053)”.
I can’t move forward with that, what should I do?
No I can see WDMYCLOUD location on my PC, but it is empty! Have I lost all my data doing “system only” reboot??

Try deleting your PC credentials and remap your My Cloud. Also did you use your old login name and password to the My Cloud Dashboard?

Try accessing the My Cloud via the Dashboard using a web browser to setup and configure the My Cloud.

http://support.wdc.com/Knowledgebase/answer.aspx?ID=13965

Yes, during the dashboard configuration I used my name, surname and e-mail address, just as during the first configuration.

I thought that the “system only” reboot solved the problem, but now even if I have the solid blue light on the front panel, I can’t access dashboard (tried Chrome, Firefox, Edge) nor mycloud.com to do the initial configuration.
No idea what happened, it is connected as has always been.

Have you tried using the IP Address of the My Cloud in the web browser to access the My Cloud Dashboard? A reset may have caused the My Cloud to obtain a different IP Address. Generally it is suggested to configure a static IP Address for the My Cloud within the router’s administration page(s) to avoid having the My Cloud change its IP Address.

I’ve noticed that the IP address changed after the firmware update on 24th May in the first place. Now I tried to access it through http://wdmycloud, I should be able to do it even if the IP address changed, right?

Normally yes one should be able to access the My Cloud using http://wdmycloud but sometimes the local router/gateway or the local PC’s retain the old IP Address for the My Cloud which causes the problem. That’s why one should try accessing the Dashboard using the current IP Address for the My Cloud as a troubleshooting step.

Ok, I tried 4-seconds reset to reboot it again and now I have red light back on the front panel AND I can’t access the dashboard. I’m getting out of options.
Is there any way to do the files recovery now?

Let’s assume it changed, how can I find the new IP?

You can find the IP Address in a number of ways. One is to access your router’s administration page and see the list of IP Addresses handed out by the router. Another, if using Windows 7, is to open up Windows File Explorer, and see if the My Cloud is listed under “Storage”. If so right click on the My Cloud icon and select Properties and the dialog box should list the IP Address. One of the WD programs (WD Access I think but I could be wrong) will also show the IP Address for the My Cloud.

Helo.
I have the same problem with the red light exactly in the same date that you said.
I open the box and tried to connect the hdd to my pc but there is a sound of clicking.
My question is : if I will change the heads of the hdd in lab if this will work and the pc will show all my files?

We are users just like you trying to help one another. None of us here are part of WD Support. To answer your question I think it would serve you better to contact WD directly.

Western Digital Customer Service:
1 (800) 275-4932
Webpage:

WD support has just recommended me a data recovery by some professional service. Great…
If you have any ideas how to recover data from a failed WDMyCloud disc, I would be very interested.
Before it got completely red/unaccessible I tried to access to my data through SSH mode (FileZilla) (that was WD support suggestion) but when I tried to open /shares I got the error message “no such directory”.
I hope the disc has not be formatted and there is still a possibility to recover my data. But afaik it can’t be just plugged to as a regular PC as a mass storage drive.