Recurring error "the last content source has been removed"

Hi, I have a WD TV live streaming to stream videos and movies stored on my computer (no NAS in between), the connection is either via wireless or wired, and the network settings on the WD TV is network share with some folders shared located on a computer running windows 7. Over the last two years has been OK, but suddenly the error “the last source content has been removed, please choose another source” appears after two/five minutes during the reproduction of movie.
The shared folders are there, the content of each folders is OK, the connection with the computers seems OK (both wireless and wired). If I select OK, and search for a new source, by defect the previous one (the network share) is selected. I do not have media server neither local drives connected. I have tried with an USB drive connected but still the same. I have looked at the forum for similar error and most deal with media stored on a NAS or using a Twonky or Tversity server, or by not removing correctly a USB drive.
I have resetted to factory default and still the same error appears quiet often.
Any solution will be acknowledged.

I believe you should try contacting WD’s Technical Support about this.