Recovery of all my data from an older MyBook Live 1TB

Hello all-

I am in need of help and I am desperate as it has now been over a year. I have since bought a MyCloud 4TB device and (knock on wood) have had no issues at all. It is hooked up to my AirPort Extreme and all network users are having no issues plus it is easy to access via from outside the network. The problem remains that I have a 1TB MyBook Live that has ALL of our wedding pictures as well as my entire iTunes Library which was 18 GB with over 4500 songs. I’d be happy to trash the MBL the second I get the files back but for over a year it has not worked. First, a year ago we bought an Apple Airport Extreme because we heard the wifi is better and boy they weren’t kidding. Speed doubled in the home and coverage tripled. When we tried to hook up the MBL, no matter what we did it didn’t see it. After trying and trying we chose the speed was important at that time and we unplugged the MBL and placed it in a box.

Since we tried to add it back a few months ago, we still can’t get it and even worse, no computer or WD software download even sees the MBL. Now, last night I tried again and was still seeing a blinking back LED and a solid bottom LED and there has been NO FRONT LED for over a year. After trying some things last night, I was on mycloud and noticed it showed the name of the MBL and listed it as unconnected (this must have known from prior years) so today I was trying again and now I get no LED’s. Not on back or front.

Some FYI’s of my system but the issue is definitely the MBL. Windows 10 PC. Connecting the MBL via the airport extreme and directly to my PC through ethernet nets nothing. The drive isn’t even seen. It will be tough to describe the sound but will do my best. When the MBL powers on, you hear

the little engine rev up (2-3 secs)
A knat like buzz (like one flew by your ear) (0.5-1 sec)
dead time (1 sec)
the little engine revs again (2-2 secs)
a “tick-tock” sound twice. (2 secs) it is approx like a tick-tock, tick-tock
Then it sounds quiet as if it shut down (10 secs)
restarts at top of this list with the rev up (2-3 secs)

So, I am sure the MBL is done but I NEED WHAT IS ON IT. I see a lot of people on this board saying contact a data recovery company but I think that WD should offer this. I can imagine taking it to someone and they rip it open and just like that I have lost our wedding photos. I keep telling my wife that I will recover them but can someone be honest with me? What are the chances of recovery?

I have reset, powered off and on, have tried making sure it is directly in an outlet not a power strip, I have tried all of the little WD downloads, I have tried to type the name of the device in the address bar but I think once you reset the name resets too but I am not positive. Open to any ideas or suggestions before my wife kills me and the only person I can talk to at that point are the others in line for the fiery afterlife.

Hi there,

Have you tried connecting the unit directly to the computers Ethernet port? Hope this can help you out.