Recovering "lost" Drives and Shares

I had to do a fair bit of searching, trial and error, so thought I would share my experience in the hope it will help others…

NOTE: This requires use of SSH to connect to your EX2, and terminal commands in linux. If you are unsure or have limited knowledge on how to navigate or use unix/linux environments and their commands, then I suggest DON’T do this as you may do far more damage.

I had a MyCloud EX2 Ultra 4Tb which had been configured as mirrored drives, with an encrypted volume. Had a number of shares and users created (it is used in a small office environment). At some point it stopped working, and when I got to look at it both drive LEDs were solid red. Trying to login to it via its IP address would give the initial setup screen. Somehow it had lost all its setup/config and I could no longer get to the data. I wasn’t even sure if it was still there :frowning:

As it would happen, I had another EX2 Ultra which had not been setup, so I tried adding the drives from the failed unit to this new one. I could merge the volume into the drive, but could not see the drive or the shares… so back to the original (failed) unit.

After searching and trying a number of things, below are the steps that worked for me and gave me access to all data and shares. What a relief!!!

  1. With the drives in the failed unit (with both drive LEDs solid red), I logged in via its IP address (found by using network tools I had) and setup the admin password and got to the dashboard to do a fresh setup. You could simply follow the setup instructions that come with a new unit.
  2. I then Imported a backup of the config I had of the EX2 (through Settings, utility tab) to load all the users, passwords, shares, etc I had previously setup. (Always keep a backup - always!)
  3. I could see my config, but still could not see the drives and data. I noticed in the Storage tab, under under Volume Encryption the link “Mount” next to the Volume_1 - so I clicked to mount the volume.
  4. It asked for the encryption password (so lucky I always keep these things), entered it and it loaded the drives and I could see the shares and access the data - phew!
    4a) Don’t forget to edit the configuration of the encrypted volume to Auto-Mount (otherwise you will be doing this each time it reboots. In Storage, click on the Volume name, click Modify button and enter password, then click the “Auto-mount” check box (no need to enter a new password), then click apply.
  5. HOWEVER, as my config was taken a while ago, there was a share that I had created more recently that wasn’t there. I could see the data was on the drive by adding up all the used data and what was free - but couldn’t get to it (and I couldn’t remember what it was called!).
  6. I found links on how to get to “lost” shares via SSH, so turned on SSH on the EX2 (via Settings, network tab), and from terminal on my Mac, ssh into the EX2. Navigating to /mnt/HD/HD_a2 and doing ls -alh I could see all my shares (plus some system ones). Most importantly the name of the share I was missing! Navigating into that directory I could see all the files that were missing.
  7. Back on the Dashboard UI, I went into Shares, created a new Share and called it the name I took from the ssh session - and hey presto - the Share was back and linked to the data I needed. I had to do the additional configuration on the share (like changing from being Public, and giving the correct user access, etc) but I had the data back!
  8. REMEMBER to turn SSH OFF under Settings tab when you are finished. Leaving it on leaves you more vulnerable to hacking attacks.


  1. Always do a backup of your NAS config every time you make a change
  2. Ensure you keep in a safe place the encryption password for your encrypted volume
  3. Have additional backups of the data (if the NAS is the master copy of the data)

Hope this helps someone!