Recovering Data From Broken WD My Book

I’m not sure if anyone can help me out with this or not, but I’m having some issues recovering the data on my external that recently broke.  It’s an old drive, I’ve had it for about five years now, but the metal port that the USB cable connects to broke off and fell inside the drive.  It’s way past warranty, so I opened it up and took the drive out to try and get the data off it.

I purchased a dock that lets me plug my HD in and connect it to my computer via USB, but I’ve encountered a bit of a catch-22:

  1. When I hook it to my computer it tells me I need to format the drive before I can access it.

  2. I ran software (EaseUS) that lets me recover deleted files on the external drive and it only recovered stuff I had deleted in the past, with no access to the files currently on the drive.

So, I can’t access the files without formating the drive, which will delete the files I’m trying to access.  I don’t want to do this, however, because the drive has practically EVERYTHING important on it that I’ve been backing up over the years.  Pictures, text documents, etc.

My only idea is to format the drive and then try to recover deleted data, since the format will have deleted the files stuck on it.  I’m not sure if that would even work though.

Does anyone have any ideas or similar experience?

Welcome to the Community and sorry you’re going through this.

Have you tried with a partition table repair software in order to correct/fix the damaged file system? This would bypass formatting if successful.

Hello DerpDog

I am exactly in the same case , my external 2 To drive, which is almost full cannot start , there is no letter drive on my disk manager and windos ask me to initilize it …I will not do that , otherwise it will erease all datas on it.

I tried lot of recovery software without success and even trying Linux Ubuntu does not see the drive …  WD tells me to try to install the firmware …but no guarantee it will works without ereasing the datas…

Have you ever found a solution ?


no solution from me, but I have experienced the same issues with several of my external mybook’s

latest incident, the drive were working without any problems and all of a sudden the drive (1TB) disappeared and turned up unformatted. All of my past month work were gone.

connected it to another PC hoping it would turn up OK, but no luck.

rebuild the filesystem, nothing worked.

recovery attempt failed (using easeus, unformat)

Have to format the drive and now starting over with the work, but the trust in these discs are getting weak.

FYI, have only used WD hardware för ages, still connected with 5 internal and 10 external drives.

hope there’s an answer to why this happens, can’t think of any other brand.

Some externals have died on me after a couple of years hardworking (uptime PC over last  5 years are @ 95%)

(I believe the main cause  of failing might me a powerissue, when i put the external  - internal with new powersupply they usually start working again)