Recover 0 kb files

Hi everyone.

I’ve been using a WD My cloud since 2014 and everything went fine, since a couple of months. The issue is that a whole folder, including, subfolders has gone to 0kb size, nevertheless i am able to see metadata from the files inside (name, extensión, creation date, etc).

Thigs I’ve tried:

1.- Copy/pasting them to my local HDD and perform a CHKDSK /f (Windows 10) without any outcome.
2.- Copy/pasting them to my local HDD and perform Pririform Recuva with the same result.
3.- Performing a complete System Diagnostic, but i’m unable to find where the hell is the report file.

Is there anyone who can help me? So many thanks in advance.

@jlorenzt I take it this is a My Cloud and not a My Cloud Home?

When was the last time you shut down your My Cloud and rebooted it?

What type of files are in the folder? For Media, when was the last time you did a Rescan?

Well, I have had some power drops at home, which I blame for the corruption….

Last time I made a reboot (through the dashboard) was yesterday.
The files are photos, both .jpg and .tiff files.
I’ve never done a Rescan, so I’m doing one right now.

Thanks for your attention, Will update this thread with results of Rescan and Reboot.

Already done Rescan and Reboot. No chanches, still unusable 0 Kb files.

Thanks for your help