Recognition as a USB 3.0 of My Passport Essential SE

Good evening,

I’m writing the following to expose a problem with the recent purchase of a unit external WD MY Passport Essential USB 3.0 SE.

In particular, once the drive is connected to the notebook, is not recognized as USB 3.0, but only as USB 2.0 ports and only NOT USB 3.0.

I have an HP 8540w notebook with NEC / Renesas USB 3.0 host controller electronics.

The laptop has 3 USB 2.0 ports and 2 USB 3.0 ports.

I tried to do the following without, so far, no results:

  1. Installing new firmware WD my passport, download the program by WD Universal Firmware Updater for Windows, downloadable from your site

  2. Installing new firmware Renesas electronics usb 3.0 host controller, the latest version of

  3. Install new BIOS vers. F20, downloaded from the HP support center

  4. WD SES Driver Installation

  5. Install latest version of WD Smartware

I state that, before the series of steps described above, the WD external drive was not even recognized by Windows 7 (64bit): in fact, once connected, the system did not emit any sound, typical of when a new device is connected (eg sound you hear when you connect a USB stick).

The unit worked at first only by connecting to the USB 2.0 port of the laptop.

In this case, Windows recognized it and allowed the installation of the WD Smartware and access to data on the disk.

If, instead, connected to the USB 3.0 ports, the system does not intervene: there was no sound, nor even any sign of loading or recognition.
The unit, however, and remained lit with white LED light sets.

After installing the new firmware my WD Passport drive and controller NEC / Renesas, by connecting the external USB 3.0 ports to Windows 7 recognizes it and makes a sound, typical when connecting external devices.

The unit is seen in the Windows Safely Remove Hardware panel as MY PASSPORT 0740, but is not recognized as an external disk, although it is on and is still recognized by Windows (no drive appears in My Computer, nor does it starts Wd Smartware).

In the event that the unit is connected to one of the 3 USB 2.0, however, works perfectly, with write speeds of the order of 15/20 MB / sec.

Surely the installation of new firmwares should have helped drive recognition, since before Windows 7 was not even able to detect it, but unfortunately does not seem to be sufficient to correct the problem.

I suggested re-installing Windows 7 on the machine after formatting the disk: in this case they could solve their problems related to the possible corruption of the USB3.0 controller driver.

I ask your friendly Support if an operation like this could solve the problem.

Eventually, if you feel that a reinstallation of the operating system does not solve the problem, I kindly ask for a consultation to get the machine to recognize the external drive as USB 3.0.

Thanks in advance.


connecting the external unit with a different USB cable (I have found a different brand USB 3.0 hard drive) to the USB 3.0 ports of my laptop, it works properly.

It is recognized by windows and I can do reading and writing operations.

The write speed is around 20-30 megabytes / sec, much like if I connect the hard disk on USB 2.0 ports

Is this normal?

Among other things, if I go on the WD site and look for that exact model of unity in my possession ( at the bottom of the page I read that in the package is provided only a USB 2.0 cable and NOT USB 3.0

How is it possible? What are the writing speed of a like unit when connected via USB 3.0?

20/30 Mbs are USB 2 transfer speeds, with USB 3.0 you can get from 90Mbs to 130Mbs. Try conneting the hard drive to another computer with USB 3.0 ports.

I just found this look at post 5. So Many mice,keyboards and card readers now connect by USB I wonder if that has any connection to this problem? Over all I think USB was not well tested before release so it is buggy and hard to figure out problems.


Changed the USB 3.0 cable with another one from another external unit (different brand/model)

MY Passport has been recognized by Windows 7

Everything seems OK

If connected to USB 2.0 ports, writing speeds are between 20-30 MB/s

If connected to USB 3.0 ports, writing speeds are between 50-60 MB/s

I was wondering if it could be a power issue (probably USB ports aren’t giving the right power to the external unit)

I think that if I 'd change the cable, by buying a Y USB cable, It could speed up to 90-130 MB/s

What do you think?

Been struggling with this issue for a while now, but seem to have solved it.

When I attached the drive to USB 2, I could see it, and it would show up as an unknown device in Device Manager.

Configure the unknown device as a WD SES Device, which you should have one of at the bottom of Device Manager under WD Drive Management devices.

Use the drivers in the Extra directory on the volume